Jump to content

Photo

Skyforge Shields SSE


  • Please log in to reply
58 replies to this topic

#1
Site Bot

Site Bot

    Fear me

  • Members
  • PipPipPipPipPip
  • 2,033,956 posts
Skyforge Shields SSE

Skyforge Shields SSE

#2
Dimitrisgrr

Dimitrisgrr

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,718 posts
Aren't these added in immersive armors ?

#3
Pchead

Pchead

    Regular

  • Supporter
  • PipPip
  • 90 posts
Finally!!! You do not know how I was expecting this. Endorsed.

#4
wolflordjsw

wolflordjsw

    Enthusiast

  • Premium Member
  • 184 posts
In response to post #44427915.


Spoiler

my though exactly.

#5
calthrop

calthrop

    Old hand

  • Members
  • PipPipPip
  • 648 posts
Dreogan, very happy to see your mods reappearing for SE! Your models are always top notch.

#6
blacktombz

blacktombz

    Stranger

  • Supporter
  • Pip
  • 6 posts
In response to post #44427915. #44428660 is also a reply to the same post.


Spoiler

Doesn't matter. There are a lot of people who dislike the overclutting of new armour models in the Immersive Armours mod. I like these shields but hate a lot of the stuff immersive armours also hands out to random npc's. Thanks Dreogan for givng us your Skyforge Shields as a standalone!

#7
lued123

lued123

    Faithful poster

  • Premium Member
  • 1,449 posts
The original version of this mod is where IA got them from.

#8
nacidocoqui

nacidocoqui

    Regular

  • Supporter
  • PipPip
  • 92 posts
By the Nine, I haven't seen this mod is a dragon's age! Insta-download and endorse! Not to push my luck, but does this mean Skyforge Swords is on the horizon for SSE, too? :D

#9
MrsNicole

MrsNicole

    Journeyman

  • Members
  • Pip
  • 46 posts
Awesome to finally see this mod! Thank you!

#10
Pchead

Pchead

    Regular

  • Supporter
  • PipPip
  • 90 posts
Something happens, I started the mission of the companions and the shields do not appear. The shield of Aela does not change and Eorlund does not have them available in its inventory.

Edit: Sorry, that happens to me for not reading. It works perfectly.

Edited by Pchead, 14 November 2016 - 02:16 AM.





Page loaded in: 0.990 seconds