Jump to content

Forge not fully loading weapon/armour previews and causing a number of options to freeze


Recommended Posts

I've just encountered this bug today all of a sudden, i've not installed any new mods and my previous playthrough have never had this bug. I've got a lot of weapons from mods but never had this issue. Basically when u go and craft a weapon or armour, you'll be able to see what you're crafting by the preview image but now it's taking around 30 or longer seconds to just show a page worth of previews which still doesn't load all the previews of the items. I've looked online but no one else seems to have this issue (or has posted one) I got CCOR in case that would fix it but it hasn't.

https://i.imgur.com/jPRmf3T- 1st weapon (have to right click and select "open in new tab" for some reason to view the images)

https://i.imgur.com/TnbUAc9 - 2nd weapon

These 2 examples have item previews, i know some mods don't have a weapon preview but majority of the mods i have do.

issues found:

  • If u exit the forge whilst its loading the item previews and go to another crafting station, your character will be just staring at the station until the time it takes for the page load of weapons to load
  • Same as above but any action you do including quitting to desktop will freeze the game until the same thing happens with issue 1
  • Once a page load of items previews load, the previous load of items it was on will reset so you have to WAIT AGAIN for those to load
  • Crafting sounds (hammering noise, pulling the rope, cooling in water) all disappear when it loading the previews
  • This only seems to happen on the forge. Gridstone, tanning rack, enchanter table, inventory and etc all work fine with no issues loading previews

I've tried LOOT and Tes5edit which hasn't solved anything.

Update: it seems to be playthrough related, I've reloaded saves and it seems fine up to a point where the problem started happening, I've done 2 things that I thought might've been the issues was items that i gave to followers, i removed and dismissed my followers to see if it was those that was causing the bug but it hasn't changed a thing.

I've also verified integrity cache but that hasn't done anything either so im completely lost

update 2: I've decided to play from the save just before the bug occurred, its been all fine so far but not knowing what caused the bug has made me frequently go back to the forge just to see if its bugged again, its made me worried playing the game in case it starts again.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...