Jump to content

Name matching: Doesn't match the file name


Recommended Posts

 

When trying to change the load order of some of my mods via the dependencies section (creating a new rule?) I get this message, "Doesn't match the file name" under the Name matching section.

The folders related are named as such:

Archived zip: "[CP] OhoDavi's StardewValley Anime Mods SVE-1.0.0"

Staging folder: "[CP] OhoDavi's StardewValley Anime Mods SVE-1.0.0" / "[CP] OhoDavi's StardewValley Anime Mods SVE"

Games mod folder: "[CP] OhoDavi's StardewValley Anime Mods SVE"

Name of the mod within the mods manifest: "[CP] OhoDavi's StardewValley Anime Mods SVE"

 

Everything is named exactly as it should, so I don't see what files don't match.

The game even loads fine. But the load order is the problem.

Because it is not recognizing the mod name properly, the deployment order doesn't change even if I set a rule in the dependency to "Must deploy after".

After doing some investigating it only does this for mods I have modified, or made from scratch for personal use, and have the "source: user generated".

What am I doing wrong?

 

vortex 1.9.12

Game: StardewValley

Mod Source: user generated

actionv2.png

Link to comment
Share on other sites

On 2/6/2024 at 3:38 AM, Pickysaurus said:

The deploy order doesn't do anything unless the two mods conflict. In the case of Stardew Valley, no mods will conflict. 

Hello, and thank you for the quick response. Although informative, this does not really help solve the problem I was having. I suppose that is my fault for not being concise. The issue I have is with the "Name matching" error (specifically the "Doesn't match the file name"). The deployment ordering not reordering based on new rules (load after, before, dependency of, conflicts with, ect.) was a side effect of this.  I disagree with the deployment order "not doing anything", but in this case of Stardew, you are probably right in that it doesn't matter in the end.

I was more interested in knowing why vortex was labeling my edited/custom mods as "not matching". The tip for name matching references glob pattern, so I kinda assume it is somehow a name file formatting thing that vortex is using, or I am just blind to some spelling error.

Even when  I copy and paste the name I still get this error, and I don't have a formatting chart to reference, but I am not using '*', or '?' characters in my name file, so I am having trouble understanding what the error is referencing/ has issue with.

Link to comment
Share on other sites

14 hours ago, Pickysaurus said:

You can add a rule between two mods by dragging the rules icon from one mod to another, if that helps? 

That is exactly how I discovered this "error" as shown in the picture. I was attempting to force one mod to deploy after/before another and I noticed that some of my mods (the ones I made/edited as user source) were reporting a name matching error. I can make rules from my mod to other mods just fine, but when I try to have others set rules to mine it gives the error. My naming sense isn't  really different from the unofficial mods downloaded from the web, and mods I have edited files for, but still have the original mod ID, File ID also have no problem.

This is less of a rule/load order/dependency issue and more of a weird vortex file formatting issue.

As I have stated before: The mods run fine, and I have tried copping the file name over exactly from the mod. So I don't know why vortex is reporting this error.

Edit: I am running on windows 11 and I sometimes get the "File path is too long" error when editing these mods. I wonder if this is somehow effecting vortex's file pathing. Sadly this is an ongoing bug in microsoft that hasn't been fixed yet. The only way to test this is to degrade to windows 10 first.

Link to comment
Share on other sites

  • 2 weeks later...

I recently: downloaded a mod from nexus, installed it, gutted all files, and replaced it with my own while maintaining the manifest.json. Not only does it work fine, but nexus no longer gives the "file name does not match error".

I think this all has to do with how vortex deals with zip file names. Usually it is: <modname>-<update#>-<version#major>-<minor#>-<patch#>-<????>

Where that last number is like a hash for the file/mod identifier or something. But what if you don't download the mod form nexus? Or from the web? How should the zip file be named then?

Or maybe I am just using the wrong source file?

The options for source are: user generated, website, other, and nexus.

Should I be using other instead?

 

On another note is semver11 even being followed?

I noticed that following the unofficial update guide for Stardew, vortex flags the mod for update (to revert it back the one on nexus) despite incrementing the patch like the guide says which should have superseded it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...