Jump to content

Help with importing cutscenes and animations in Blender

Recommended Posts

Hello everyone.

TLDR: I can't for the life of me figure out how to load an animation on my character, much less morph faces.


The post was originally longer because I struggled with ModKit and Wolven Kit but I eventually figured it out. So I changed my post for it to be more concise and go the main problem that remains.

I would like to use Blender and Cycles to make custom renders of the game and characters. I decided to try using this plugin : https://github.com/dingdio/Witcher3-Blender-Tools?tab=readme-ov-file. I installed it as well as APX plugin, and after a bit of messing around, I could import the complete model of my character with all his materials and textures, I could even extract other versions of him from other mods and give him new outfits extracted from the game using Wolven Kit.

Then I tried to import and give him animations, and this is where I'm stuck now. I followed this tutorial : https://www.youtube.com/watch?v=BvXJYPMr2gs to import the base rig of a man from the game. This is where I noticed that the uncooking of the game that I had made with ModKit hadn't output any rig or anim or cutscene, and I had to go extract them with Wolven Kit. Once it was done, I could indeed put an animation set from the game onto that rig. But when I tried to put the animation on my character rig (who has several armatures and as I'm not very savvy in animation, I don't know if there's a special thing I should do here), I have this error:

TypeError: ActionGroups.new(): error with keyword argument "name" - Function.name expected a string type, not int

I tried transferring the animation from the base rig to the armatures of my character making a Ctrl + L > Link animation data, but my character's model remains still. In desperation, I even exported both the animation and my character model in FBX and tried to recombine them into another Blender scene, but it gives very random results when I try to link the animations, mostly resulting in my character's model to be completely distorted.

Okay so at this point I wanted to try one last thing. My goal, as I said, is to make renders in Blender. I need different poses, backgrounds and expressions. So I thought that maybe importing a cutscene, as showed in this tutorial https://www.youtube.com/watch?v=bAlOcozN-Ws, would at least give me some leeway. So again, I noticed that my uncooked game hadn't uncooked any cutscene. I went and searched for a cutscene with wolven kit, and extracted it. But when I tried to import it in Blender, I had yet another error, saying that scabbards_crossbow.w2rig was not found in my Uncooked folder. I went and extracted it from Wolven Kit, and I had to do that for several rigs until the scene would eventually load in Blender. But when clicking on one of the sequences, I have the exact same error as before.

Anyway if you're still here after reading all of this, thank you and I'd be grateful if you could shed some light on this, because I'm about to give up modding for the Witcher 3 lol, honestly...




Edited by Galadriel28
Link to comment
Share on other sites

Okay I'm replying to this topic myself because I made some progress. Mainly :

- I found out that wcc_lite uncooking doesn't natively export anims, cutscenes and rigs so it's normal to have another go at them through Wolven Kit

- I found where to download W3Oven which works WAY better than ModKitchen : https://forums.cdprojektred.com/index.php?threads/w3-oven-an-alternative-gui-to-modkit-1-3.7004360/

I still have the problem of animations not being transferable to my character rig in Blender, as well as loading cutscenes. I'll have to investigate this further, but if you guys have some tutorials or workflow to share, I'd be happy to read from you!

Edited by Galadriel28
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...