Jump to content



Recommended Posts

Hello. I'm new on the nexus, really this is my first ever forum post ever. I don't know on which discussion I should post this topic in but this seems most appropriate- if it is not, I apologize.

I'm not sure if this is region specific or not, but I am really starting to get frustrated with this. If you are in Australia also and are experiencing the same thing, I'd appreciate knowing.

A few days ago, I tried to go onto nexusmods (I use google chrome) because I wanted to change up my load order, and add something new. However, the website wouldn't load. At all.

Whenever I try to load it, the page says:

"This site can’t be reached

The connection was reset."

I tried using internet explorer, and came up with a similar result:

"Can’t connect securely to this page

This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner."

I ended up going to iidrn.com to see if the server was down, however last time I checked, it says it's running fine. So I don't know what the issue is, but it just refuses to load for me.

As far as I know, my nexus mod manager client itself can connect just fine, it is just the matter of accessing the website that is the issue. I'm able to access the website on my phone's browser, yet not my computer. I may use my phone as a hotspot to load the pages until I can fix this, but it's not the best long-term solution.

Searching online so far has garnered no result, and I have no idea on where to even start to try and remedy this. I'm starting to think it may be something to do with my internet connection- please note that all other usual websites are running fine though- or my ISP, because it works fine on my phone, but not on my computer. But as I said, I still don't know what to do to gain access to the website again, normally.

In short: nexusmods.com is completely inaccessible (will not load, "site can't be reached") for me, and has been so for the past two days- possibly more, but I hadn't attempted to access it before then. Help?

Link to comment
Share on other sites

AN UPDATE: I seem to have managed to fix this problem on my own, so I thought I'd document what steps I took in order to be able to go on the nexus again, in case anyone else has the same (ERR_CONNECTION_RESET), or similar problem trying to access the website.


I first opened my command prompt (an easy way is to press "windows key + r", type in "cmd" and hit enter). After that was up, I typed in the following command:


  • netsh winsock reset


Then I restarted my PC, before opening command prompt again, and typing in the following commands, in this order:


  • ipconfig /flushdns
  • ipconfig /registerdns
  • ipconfig /release
  • ipconfig /renew


Remember to hit 'enter' after entering each command. After entering these, I then restarted my PC a second time.


Right after taking these actions, I was still not able to access the nexus, yet when I left my PC be for a few hours, then coming back, I was able to access nexusmods again. I'm assuming it just needed some time to sort itself out or something of the like.

Link to comment
Share on other sites

  • 6 years later...

(sry for the bad grammer englis isint my main language )Hey man i dont know if you still need it but i found an less complicated way to do it you do it by turning off all cookies that is it it worked for me

Link to comment
Share on other sites

i can't acces the site from operaGX, the very same browser that i first used to download vortex and all the mod i use, was working fine a couple month ago when i first did the modding, but then it just show me some error stuff (image bellow) it's quite a problem since even when i change my main browser in my computer parameter, it still open opera and refuse to let me update my mods, and after looking up this problem i saw that other had the same issue and none of the solution proposed by randoms worked.

any solution ?

thanks for your consideration and time

a fellow player

contact for non-moderation team who have potential solution  :  Discord : rasetamanche



Capture d'écran 2024-04-08 160614.png

Link to comment
Share on other sites

  • 3 weeks later...
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...