Jump to content

Guide: How to get rideable, summonable Dragon-companion


Recommended Posts

First of all: I DO NOT take credit of anything. I have not created the mods featured in this guide. Only things I even could take credit for is the featured video, and the realization itself.


Rideable dragon companion is what everyone has hoped for since Skyrim came out. Even though there are dragon follower-mods, none of them is rideable, as far as I know.


Of course, when Dragonborn-DLC came out, we were introduced to "Bend Will"-shout and ability to ride wild dragons, if one can call it "riding".


But that was not quite what I and probably many others were hoping for. Even with "Bend Will"-shout, the dragons were one-use-only, and not our allies, but enemies. And with crappy dragon flying that vanilla-Skyrim had, it was not even close for what I hoped to see.


Of course, making a mod with dragon, which acts as companion, and is rideable at the same time, must be extremely difficult, if not even impossible. I do not blame anyone for not making a mod like that.


But, as I am going to show you, there is a way to have dragon companion, which is also rideable.


For this you need:


Ring of Dragons-mod, by Wyrm1331



Command Dragon - Ultimate Dragon Riding-mod, by rongphale



And "Bend Will"-shout.


For me it was extremely annoying to chase down a dragon, or look for ID and spawn one every time I wanted to ride. Also, when I finally got one, it tried to kill me, and could care less if someone else tries to attack me. Ring of Dragons fixes this: It gives you ability to summon a dragon, which fights for you and follows you by flying. It has no dialogue, but why would you need it?


Well, after I had my own pocket-dragon, I by chance wanted to see if the Bend Will-shout would work on it. And it did.


I'm not sure how to get the ring without console. With console you'll need to use these commands:


help "ring of dragons"


and when you have the ID,


player.additem (ID)


To get the words of this shout, you need to play through the Dragonborn-DLC. But if you don't feel like it, you can get the shout with console, and I'll explain it here.


First you need to learn the words. This is done by using player.teachword -command. After the command you must add the IDs of the words, which are:


xx0179d9 (Gol)

xx0179da (Ha)

xx0179db (Dov)


If you are wandering, what the "xx" are, they show the placing of Dragonborn DLC in your loading order. For me it would be 06, as Dragonborn is the sixth plugin. To find out easily what it would be for you, open the console and write this:

help "Bend Will"


This should show the ID of Bend Will shout. The first two numbers of the ID are also the "xx" numbers of the words.


After you have learned the words, you need 3 dragon souls. If you don't want to hunt down dragons, write this to console:


player.modav dragonsouls 3


Use the souls to unlock all three words of the shout.


If you don't want to wait forever to shout to cool down when the aiming goes off, type this to console:


player.setav shoutrecoverymult 0


This sets ALL shout-cooldowns to none. I almost never use other shouts, so it's not too overpower for me; but judge yourself.


Full-charged Bend Will-shout will make the dragon, which you summoned with ring, rideable.


...great. The vanilla-version of riding is phlegmatic at most. To get full control over your dragon, and REALLY ride it, you need The Ultimate Dragon Riding-mod.


I'll be honest. To get this mod to work can be a pain in the butt. But, despite all the comments that it's impossible to get to work, I can say, and show, that it does work. And when you get it to work, it is worth it.


These steps got it working for me. Especially the loading order can variate, so keep trying and don't give up. It does work, and you don't need superior-computer for it.


1. Install SKSE. Not the 1.7.1, but the 1.7.2 or higher. It seems to be must. You need the latest patch for it to work.


2. Install latest SkyUI.


3. Install the mod manually. Download the zip-file and put everything into Skyrim\Data-folder.


4. Start a new game, with only the absolutely necessary mods activated in addition to the Command Dragon-mod. This gives the game resources to get it registered by MCM. Give it at least 10 minutes time to get itself together. You can play, or wait, but don't rush it. After it is registered, feel free to activate the other mods.


If it does not register, try change the loading order. For me it seems to need to be right below DLC's and patches, above everything else. Some say it should be last. So keep trying. Also, I have noticed that using Alternate Start - Live Another Life by Arthmoor (http://www.nexusmods.com/skyrim/mods/9557/?) makes the mod register much faster, at least for me.


Starting a whole new game is no longer necessary! Thanks to the help of darktitan17, we found out that you can get the mod work in already started playthrough. The steps are following:

1. Install SKSE, SkyUI and mod, manually. After that, activate them either through Skyrim Launcher or Mod Manager / Mod Organizer, and load up your save.

2. Open the console and type: SetStage SKI_ConfigManagerInstance 1.

This should make the MCM to check all the menus and add missing one.

3. If the console command doesn't work for you, download Jaxonz MCM Kincker by Jaxonz and install it. This mod should literally kick MCM to get itself together and find and add the missing menus.


When it is registered by MCM, you're done. Congrats!


After you have this, only thing left is the fun part. Summon your dragon, shout at it, and ride it as you please! The video below shows how it's done in practice.




Note: Sometimes the dragon will glitch; spin around in the sky or fly inside the ground. This happens usually when you have summoned and unsummoned the dragon many times in short period of time. The shout will still work on it, though. One way to try avoid this is to quick save before summoning the dragon. If it starts to act up, load the game. If it still glitches, try to do something else for a while or wait about an hour in-game-time. Also riding and then landing will reset it back to normal.


Feel free to ask, comment and criticize!


I humbly apologize if this guide is posted in the wrong section.

Edited by Halihaisku
Link to comment
Share on other sites

  • 1 year later...
The teachword commands are not working for me.. everything up to that part has been easy.. what is (Gol)? Is there something i need to put after that? Do i need the parentheses around it? I did what was asked word for word letter for letter other than the xx my dragonborn dlc was 06 as well so of course i incorporated it as such.
Link to comment
Share on other sites

  • 2 weeks later...

I'm very, very sorry for this long delay! I have unfortunately been busy due issues in real life.


Anyway. You said you can't control the dragon. Do you mean you can fast travel with the dragon but not tell it where to go otherwise? If so, that would mean that Ultimate Dragon Riding is not working. When you mount the dragon, do you get a notification on the top left corner, saying per example "Mount the dragon" or "Orbiting around"? Is the mod listed in your MCM menu?


If you get the messages, then it could be problem with the controls. When you mount the dragon, it should stay still in the air, or hover. Use A and D to turn the dragon to face the direction you want, and then first press S and then quickly pres and hold W. You should first get a message "Orbiting around", followed by "Flying forward". Dragon should try to fly towards the direction it was pointing. If the dragon flies in circles, or orbits, just press S once, wait for the dragon to hover, and the rest works the same way.


If you do not get the notifications but you see the mod in MCM menu, or if the controls listed above don't work, click the "Command Dragon" tab and choose there the General. There should be option "Reset Mod". Check the box, close the MCM and wait. This will try to fix the bugs occurring in the mod, such as not be able to control the dragon.


If you don't get notifications and the mod is not listed in MCM, download and install Jaxonz MCM Kicker. It should help the game to find the MCM menus that are missing.


I hope these answers will be helpful. Sorry for long delay, I try to answer faster in the future.

Link to comment
Share on other sites

  • 2 months later...

Hi there! I don't have an answer from the top of my head, but here are some suggestions.


Do you get a notification from the Jaxonz MCM Kicker, saying something along the lines of "Checking missing menus"? If not, it means that the mod is not for some reason working as it should. After loading your save, transit from outdoors to indoors, fast travel, etc. As the Kicker only runs when the game loads, it may be that you need to cause a loading screen.


Do you use any mods that require a patcher? Perkus Maximus, Requiem, ASIS... If you do, make sure to run all the patchers after activating the Dragon Riding mod. It may be that outdated patch keeps the mod from starting.


Have you tested, if the mod works with a new game? If not, give it a go. Start a new game with all of your mods and if the mod doesn't show up, try again with only most necessary mods activated. If the mod does show up, it would indicate that the problem is somehow in your current game; perhaps the current game is too script heavy for Dragon Riding to run? If it wont, the problem is in the installation, requirements or loading order. It never hurts to double check; is the mod activated, is everything up to date... I know by my own experience that it is possible to make quite interesting mistakes, like raging 2,5 hours to a mod which was never turned on.


Do you use LOOT? If not, you can get it here: https://loot.github.io/ It's a program which tries to give you best loading order possible and also inform you about conflicts between mods. It may be worthwhile to check, that there are no mods that are incompatible with each other. Even if the conflict is not with Dragon Riding, it still may block it from working.


Lastly, try changing your load order. Usually Dragon Riding needs to be either on the very top, right after DLCs and patches, or at the very bottom. If everything else is as it should be even after double-checking, it may very well depend on the placement.


I hope some of these will be helpful, tell me if there is any progress / new information, and I will try to come up with a solution.

Link to comment
Share on other sites

  • 2 months later...

Hi there! It's not a bother at all. I made this guide to give a hand to others and I try to help in any way I can even though I'm not expert at all.


You said it works in a new game. That's good news, at least there is no bigger problem that keeps it from working. Do you get the MCM menu when you activate it in your existing game? If not, have you tried Jaxonz MCM Kicker?


Do you have a lot of mods or heavy mods in your game, per example Sand of Time or Frostfall? If the Kicker doesn't do the trick, one possible way is to temporarily uninstall and deactivate some of those mods to give the game resources to activate the Command Dragon mod. It is a little risky, as for a short moment your save depends on the scripts that are no longer there, so back up your saves before trying. Or, if the mods you use can be turned off without uninstalling from MCM, it can be safer and quicker way to free some resources for the new mod.


Also, after a little digging, I found that you can try to enter this to console:


setstage Dragonmount_Rong 255

stopquest Dragonmount_Rong

startquest Dragonmount_Rong



I have not myself tried it but it was suggested by the author themselves as possible solution for problems with the mod so it can be good idea to give it a try.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...