Jump to content

mods download blocked?


Recommended Posts

hi All,

Loving the nwn2 game so far... I played D&D before there were vid games for it.

Oops! that dates me! O well.

I am an old modding gamer via the Elder Scrolls games, especially Skyrim.

Because I am enjoying nwn2, I thought some simple mods to character bods & texture, so forth, would be nice. I downloaded the Xaltar head and face mods to begin. I was able to extract and place my 1/2 elf and the Elanna mods.. also some module and texture folders into my override folder. (These worked & look grand).

But Now, I am unable, literally, to get any other mods to even download!

emote - perplexed.

I have restarted computer; restarted firefox (is that browser the problem?); tried opening other mods other than Xaltar's ... I get nothing...

I am on a new Dell gaming computer Windows 10 Home installed.

Any other specs needed to see, just ask; however,

I suspect I have triggered some blocker unknowingly.

As much as I abhor microsoft's web browser edge, I guess I could retry the dls that way.

But I thought I to ask the community too; because some times there is something ridiculously obvious that I wouldn't think of that I've left out or whatever.

Thanks, always, to all of you. This seems to be a very supportive community and that is real cool to see. I appreciate any ideas, because everything is a good review...even if it is not the prob.

Have fun!

xo Lada



Link to comment
Share on other sites

I had the same problem a few weeks ago. I don't know if it was Edge or my anti-virus software but it fixed it self a day or so later. You might try over at neverwintervault.org they have almost the same mod's and hak's as Nexus. Some builders do prefer one over the other so both places do have some unique mods.

Link to comment
Share on other sites

  • 10 months later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...