Jump to content

Photo

Fallout 3 keep freezing


  • Please log in to reply
39 replies to this topic

#1
varathiel

varathiel

    Newbie

  • Members
  • Pip
  • 15 posts
Hello,

I know this is a common problem and many have had and solved but I can not fix it....After installing a few mods, the game crashes within minutes and i have to restart everything.

I have installed the latest patch, FOSE ,and changed the parameters of .ini file (Fallout_default.ini) by adding the string "iNumHWThreads=2" and changing "bUseThreadedAI=0" with "bUseThreadedAI=1" in the "General" section and now everything is worse than before. (least the first 10 minutes of play gave them to me, now sometimes is a matter of seconds).

Any suggestion?

P.S. : I do not know if this can be the cause but I have not installed FOMM (the PC refuses to install).


Thanks in advance.

#2
MagusHabilus

MagusHabilus

    Enthusiast

  • Members
  • PipPip
  • 138 posts
Windows 7?

Same problem.the only thing I've found to cut the lock ups is run windowed on crap graphics with the black and white mod running and even then it does it almost like clockwork.
Are you running a Compaq too?

P.S

I've tried it with no mods at all as well,same thing.
I've used every utility and fix this site has to offer.
its either Windows7 or my processor I think.[dual core AMD]
when I get a single core and it fixes it or does not,I'll post that as well.

Hope somebody can help us,I feel your pain!

Edited by MagusHabilus, 29 August 2011 - 07:08 PM.


#3
varathiel

varathiel

    Newbie

  • Members
  • Pip
  • 15 posts
Packard Bell, Windows Vista

#4
MagusHabilus

MagusHabilus

    Enthusiast

  • Members
  • PipPip
  • 138 posts

Packard Bell, Windows Vista


How many cores on your processor?have you tried this?

Fallout 3 alternative crash to desktop fix.

Hi all, thought I'd better share this piece of info with everyone possible as it took me 2 days of the crash to desktop scenario to figure out.

This fix doesn't involve much at all & it sorted my problem out without any decrease in graphics, after I'd removed all traces of nero, a virtual drive, ffdshow & tried every set of drivers for my FX7950 from 2007 up to the most recent which were already on before I started Fallout 3 & updated using both updates ...15 & ...35

Click your Start menu & in "Run" type "dxdiag", when the DirectX Diagnostic Tool window appears click the "Display" tab at the top.

In the DirectX Features click "AGP Texture Acceleration" to "DISABLED"

That's it!

As I said, it took me 2 days of trying every suggestion on the internet to fix this desktop crash. All of them unsuccessfully, before that "eureka" moment.

Hope this helps. Especially to those that have been reduced to a gibbering wreck! As I'm sure there'll be a few!

PS: I'm using XP Sp3 with an Athlon64 3200 & 2 gig of RAM with a PCI-E FX7950GT 256mb

Fallout 3 crashes when loading interiors

If you have a multi-core CPU, like the Quad, and you experience a Fallout 3 crash when loading interiors (the PC version of Fallout 3, specially in closed spaces). It seems that this crash is caused by a bug in Fallout which doesn't adapt multi-threading well, and this PC game stops responding in small areas.
Fallout 3 crash fix

The fix for this Fallout 3 bug is very easy: just copy and paste and you are ready to go:

Open the folder My documents / My Games / Fallout3
Edit the file FALLOUT.ini.
Inside FALLOUT.ini look for a group called [general].
Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1
iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

And that's it: you should have fixed the Fallout 3 crash when loading small closed interior areas. Well, Fallout 3 could stop responding sometimes, but these crashes won't be a frequent bug in Fallout.



Fallout 3 on Windows 7 w/quad core
Vista SP2 with a dual core worked fine. After upgrading to a quad core and Windows 7, I was lucky if I could play more than 5 minutes without a freeze.

A fine gentleman named Nicholas Head posted this solution on his blog. Along with several others, I can confirm this fix works! (YRMV)

Fallout 3: Video/Display Freezes, sound keeps going

by Nicholas Head 7. February 2009 00:35

Ever since Bethesda came out with the 1.1 patch for Fallout 3, I couldn’t play the game anymore. Once I got into the game and started wandering around, I’d randomly “freeze” up… the video would stop updating, but the sounds/music would still play. Keyboard clicks and mouse clicks did nothing, requiring me to ctrl+alt+del and kill the task manually.
It looked like I was SOL until the next patch, but I found some help online:

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2
This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

Surprisingly, this worked like I charm. I do indeed have a quad core processor, so it sounds like this was the culprit. Why 1.1 broke the game for me.. I have no idea. It sounds like Bethesda needs to do some better testing on multi-core processors.

It helped mine a bit,maybe you'll have better luck?

#5
varathiel

varathiel

    Newbie

  • Members
  • Pip
  • 15 posts
I'm sorry to bother you again ,but in the DirectX Diagnostic Tool window - Display tab, AGP Texture Acceleration is enabled and i don't have the option to disable it, could be a problem of missing drivers?

#6
TCat

TCat

    Newbie

  • Members
  • Pip
  • 16 posts

I'm sorry to bother you again ,but in the DirectX Diagnostic Tool window - Display tab, AGP Texture Acceleration is enabled and i don't have the option to disable it, could be a problem of missing drivers?


SAME HERE (no option to disable "AGP Texture Acceleration" my drivers are all up to date .... same exact problem video freezing but sound continues.

Build (Oct 2011) Z68 (Realtek ALC892 Audio)/2500K/570gtx/Win7SP1-64bit ...
Fallout 3 GOTY (2 dics) w/without Unoficial_Fallout_3_Patch_-_Installer_Version-3808.exe ... NO Mods yet :(

Someone should sticky all these Win7/Quad+ core problems with relavent solutions and send Bethesda a bill? :O

#7
shadowfx78

shadowfx78

    Wasteland Mercenary

  • Members
  • PipPipPipPip
  • 1,264 posts
I am having the same problems tried the other fixes with the ini file and i cant change the AGP thing.

#8
avianmosquito

avianmosquito

    Enthusiast

  • Banned
  • PipPip
  • 237 posts


Packard Bell, Windows Vista


How many cores on your processor?have you tried this?

Fallout 3 alternative crash to desktop fix.

Hi all, thought I'd better share this piece of info with everyone possible as it took me 2 days of the crash to desktop scenario to figure out.

This fix doesn't involve much at all & it sorted my problem out without any decrease in graphics, after I'd removed all traces of nero, a virtual drive, ffdshow & tried every set of drivers for my FX7950 from 2007 up to the most recent which were already on before I started Fallout 3 & updated using both updates ...15 & ...35

Click your Start menu & in "Run" type "dxdiag", when the DirectX Diagnostic Tool window appears click the "Display" tab at the top.

In the DirectX Features click "AGP Texture Acceleration" to "DISABLED"

That's it!

As I said, it took me 2 days of trying every suggestion on the internet to fix this desktop crash. All of them unsuccessfully, before that "eureka" moment.

Hope this helps. Especially to those that have been reduced to a gibbering wreck! As I'm sure there'll be a few!

PS: I'm using XP Sp3 with an Athlon64 3200 & 2 gig of RAM with a PCI-E FX7950GT 256mb

Fallout 3 crashes when loading interiors

If you have a multi-core CPU, like the Quad, and you experience a Fallout 3 crash when loading interiors (the PC version of Fallout 3, specially in closed spaces). It seems that this crash is caused by a bug in Fallout which doesn't adapt multi-threading well, and this PC game stops responding in small areas.
Fallout 3 crash fix

The fix for this Fallout 3 bug is very easy: just copy and paste and you are ready to go:

Open the folder My documents / My Games / Fallout3
Edit the file FALLOUT.ini.
Inside FALLOUT.ini look for a group called [general].
Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1
iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

And that's it: you should have fixed the Fallout 3 crash when loading small closed interior areas. Well, Fallout 3 could stop responding sometimes, but these crashes won't be a frequent bug in Fallout.



Fallout 3 on Windows 7 w/quad core
Vista SP2 with a dual core worked fine. After upgrading to a quad core and Windows 7, I was lucky if I could play more than 5 minutes without a freeze.

A fine gentleman named Nicholas Head posted this solution on his blog. Along with several others, I can confirm this fix works! (YRMV)

Fallout 3: Video/Display Freezes, sound keeps going

by Nicholas Head 7. February 2009 00:35

Ever since Bethesda came out with the 1.1 patch for Fallout 3, I couldn't play the game anymore. Once I got into the game and started wandering around, I'd randomly "freeze" up… the video would stop updating, but the sounds/music would still play. Keyboard clicks and mouse clicks did nothing, requiring me to ctrl+alt+del and kill the task manually.
It looked like I was SOL until the next patch, but I found some help online:

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2
This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

Surprisingly, this worked like I charm. I do indeed have a quad core processor, so it sounds like this was the culprit. Why 1.1 broke the game for me.. I have no idea. It sounds like Bethesda needs to do some better testing on multi-core processors.

It helped mine a bit,maybe you'll have better luck?


Can't change the AGP setting in DXDiag. The rest didn't do a f***ing thing.

Little correction: Steam users need to edit the file "Fallout_Default" in steam/steamapps/common/Fallout3 instead. Still doesn't do a f***ing thing, by the way.

Edited by avianmosquito, 06 June 2012 - 08:11 AM.


#9
shadowfx78

shadowfx78

    Wasteland Mercenary

  • Members
  • PipPipPipPip
  • 1,264 posts
yup doesnt fix a flippin thing. plz anymore help plz im at my wits end here.

#10
avianmosquito

avianmosquito

    Enthusiast

  • Banned
  • PipPip
  • 237 posts

yup doesnt fix a flippin thing. plz anymore help plz im at my wits end here.


Me too. I paid good money for the game, spent twelve hours working on a mod and now... doesn't run. With or without the mod, with or without the DLCs. I want my money back. And my day.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.908 seconds