Jump to content

Photo

Skyrim Offline


  • Please log in to reply
23 replies to this topic

#1
JGARYP

JGARYP

    Stranger

  • Members
  • Pip
  • 5 posts
I know this question has probably been answered time and time again, ad infinitum, but I haven't been able to find a definitive answer, so please pardon me.
I was recently on a Caribbean cruise and found, much to my dismay, that I couldn't play Skyrim because the ship did not have wi-fi in all of the staterooms. Also, the internet connection in the various hotspots around the ship were abysmally slow. Whenever I tried to play Skyrim, I got an error message saying that there was no internet connectivity and therefore I could not play, EVEN after clicking on the "Play offline" button it offered.
So, what did I do wrong? Is it possible to play Skyrim without an internet connection? If so, how?
Thanks in advance for your patience.

JGARYP

#2
JanusForbeare

JanusForbeare

    For Morrowind! For Dres!

  • Members
  • PipPipPipPip
  • 1,545 posts
Seems to me what you did wrong was waste your time on a Caribbean cruise trying to play Skyrim.

#3
scot

scot

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,515 posts
You need internet to install skyrim on your steam account, after that you can start steam offline and play skyrim without internet.

#4
Hosam

Hosam

    Newbie

  • Members
  • Pip
  • 17 posts
I play Offline by default. I live in a country with slow connection speeds. I think I know what your problem is. A few things to keep in mind.

1- You need to be online in order to select the offline option, so you cant quit Steam in an online state and then start it without internet connectivity. You need to connect to the steam servers and then select offline for it to work. After that you can start up in offline mode until the next time you choose start an online session of steam.

2- By default an online session of steam will start downloading updates for any games you have. If an update has been started, the game will not be available in offline until the download is complete. So what I think happened in your case is that you connected to the steam servers, but an update started before you went into offline mode. At this point trying to launch Skyrim in offline mode will give you the error "the game is not ready to be played in offline mode."

For future trips I would advise:

1. Switch to offline mode before traveling and keep steam in offline mode during the trip.
2. While in online mode, right click on Skyrim in your steam library and select "Properties" from the pop-up menu, go to the "Updates" tab and change the option "Always keep this game up to date" to "Do not automatically update this game". That way an update should not start when you are looking to switch to offline mode and make the game unavailable to you.

3. Optional: For a better gaming experience, I also suggest you select Steam >Settings and go to the "In-Game" tab and disable the "Enable Steam community in-game" option. I hate the steam community pop-ups in the game and this will disable it

I hope that helps!

Edited by Hosam, 03 January 2012 - 07:08 PM.


#5
thelonewarrior

thelonewarrior

    Fan

  • Members
  • PipPipPip
  • 468 posts

You need internet to install skyrim on your steam account, after that you can start steam offline and play skyrim without internet.


Actually this is wrong, you can set any settings on steam how you like. But if there is an update avaliable to either steam or skyrim, just connecting to the interent for 1 second is enough for steam to detect this update.

I live in an area with little or no internet wifi, making it very difficult to get a signal.

On multiple occasions I have had the problem where it wont let me play skyrim without a connection to steam.
My settings are always set to play offline, and I have disabled all possible connections to steam. However now and again I try to play skyrim, and get the message It cant connect to steam, so I select play offline and what does it tell me?

It says this:
This action cannot be conpleted without a connection to steam.
Which translates as:
'I need a connection to steam online to switch to offline mode'
Which monkey at steam decided it would be fun to not allow people to change to offline mode unless already online.
granted this doesnt happen everytime, but does happen about 30-40% of the time.
So sometimes im left for days without being able to play skyrim.

#6
JGARYP

JGARYP

    Stranger

  • Members
  • Pip
  • 5 posts

Seems to me what you did wrong was waste your time on a Caribbean cruise trying to play Skyrim.

Apparently you didn't read my post. I couldn't play Skyrim on the cruise, so I didn't waste ANY time doing that.
However, if I had been able to figure out how to play Skyrim on the cruise, I would have wasted some time doing that, I admit. The problem was that all the hot tubs were full every time I went to find one, and the outside pools were too cold to really enjoy. Since I don't drink, that left very little for an adult to do on a cruise.

#7
JGARYP

JGARYP

    Stranger

  • Members
  • Pip
  • 5 posts

I play Offline by default. I live in a country with slow connection speeds. I think I know what your problem is. A few things to keep in mind.

1- You need to be online in order to select the offline option, so you cant quit Steam in an online state and then start it without internet connectivity. You need to connect to the steam servers and then select offline for it to work. After that you can start up in offline mode until the next time you choose start an online session of steam.

2- By default an online session of steam will start downloading updates for any games you have. If an update has been started, the game will not be available in offline until the download is complete. So what I think happened in your case is that you connected to the steam servers, but an update started before you went into offline mode. At this point trying to launch Skyrim in offline mode will give you the error "the game is not ready to be played in offline mode."

For future trips I would advise:

1. Switch to offline mode before traveling and keep steam in offline mode during the trip.
2. While in online mode, right click on Skyrim in your steam library and select "Properties" from the pop-up menu, go to the "Updates" tab and change the option "Always keep this game up to date" to "Do not automatically update this game". That way an update should not start when you are looking to switch to offline mode and make the game unavailable to you.

3. Optional: For a better gaming experience, I also suggest you select Steam >Settings and go to the "In-Game" tab and disable the "Enable Steam community in-game" option. I hate the steam community pop-ups in the game and this will disable it

I hope that helps!

That helps a lot. Thanks.
Just to be clear, it's Steam that I need to switch to offline mode, not Skyrim, correct? Then Skyrim's properties and updates to "Do not automatically update this game."
JGARYP

#8
Hosam

Hosam

    Newbie

  • Members
  • Pip
  • 17 posts

That helps a lot. Thanks.
Just to be clear, it's Steam that I need to switch to offline mode, not Skyrim, correct? Then Skyrim's properties and updates to "Do not automatically update this game."
JGARYP


Yes steam is switched to offline mode. But Skyrim properties can only be changed in steam online mode, so you need to do the changes I suggested while in online mode and then switch steam to offline mode.

#9
JanusForbeare

JanusForbeare

    For Morrowind! For Dres!

  • Members
  • PipPipPipPip
  • 1,545 posts


Seems to me what you did wrong was waste your time on a Caribbean cruise trying to play Skyrim.

Apparently you didn't read my post. I couldn't play Skyrim on the cruise, so I didn't waste ANY time doing that.


Hence the word "trying".

Anyways, don't take it seriously, it was just a friendly jab. I'm glad you got your answer in the end.

#10
GoodfellowGoodspring

GoodfellowGoodspring

    Howdy Hai!

  • Members
  • PipPipPip
  • 754 posts
Why would you take a laptop on a Caribbean cruise? Wouldn't it get wet at some point?




Page loaded in: 1.011 seconds