Jump to content

Photo

Boots not scaling properly...


  • Please log in to reply
2 replies to this topic

#1
scorrp10

scorrp10

    Regular

  • Premium Member
  • 78 posts

I got this rather weird case, wonder if anyone may have an insight.    

 

It is for this mod:   https://www.nexusmod...tion/mods/41532

 

All pieces work fine except for the boots.    Regardless of the weight of character wearing them, the game uses the 100 weight model.   On a 0 weight character, the thigh bands are sorta 'floating' around the legs.

 

The boots are built in BodySlide to same body preset as other outfit pieces, and it is set to generate high/low weight.   If I delete the heels_0 and _1 nifs from the directory, an then build, new files appear there.

If I preview in BodySlide and move weight slider to 0, I see the model shrink as expected.   I imported the built top_0.nif in the studio  and added the heels_0 nif on top of it - perfect fit. 

 

The .esp is definitely pointed to those .nifs.

 

I thought that maybe the heels_0.nif being generated is somehow invalid and game ignores it.  So I deleted heels_1.nif, and made a copy of heels_0.nif renamed to _1.   OK, NOW  they were snug on a 0 weight NPC.   But of course clipped like crazy into a 100 weight one.    Which proves that those ARE the nifs being used and that heels_0.nif is generated correctly.   Just not used somehow.

 

I tried building the outfit to a different body preset.  The body shape definitely changed, but again - boots snug only on weight 100, loose on weight 0.  Tried the non-3BA version - same result.

 

I thought maybe game was bugged in general, but I tried several thigh boots from other mods.   None of them have the issue.   Proper fit at any weight.

 

Any ideas anyone?    Thanks!

 

 



#2
Hanaisse

Hanaisse

    Fan

  • Members
  • PipPipPip
  • 460 posts

One thing you can check - load the mod in xEdit, find the ArmorAddon record for the boots. In the box labeled DNAM you should see a line named Weight Slider - Female. Make sure it says "Enabled".

 

If it's blank you can change it, double click (slowly) in the value box until you get a drop down menu, tick Enabled.



#3
scorrp10

scorrp10

    Regular

  • Premium Member
  • 78 posts

Thanks!   This indeed was the issue.  I actually did find this setting earlier today, after I figured the problem must be in the esp and not with the .nifs.    Thing is, I been using Creation Kit to inspect the ArmorAddon and Armor entries and compare them to some vanilla stuff, and CK has no mention of this property whatsoever.   So I figured I'll take a look in SSEEdit, and there it was.   

 

Was enabled only for Weight Slider - Male, blank for Female.   And I am wondering how the heck the mod author got it that way.   

Creation Kit does not expose the property, it just auto-sets it to Enabled when a given gender Biped Model is assigned a .nif file ending in _1.

 

Guess .esp editing was all done via XEdit, ArmorAddon for feet was copied from some other form using a singular female model, and then changed to use the heels_1...

 

Oh well, got it fixed and dropped a note to mod author.

Thanks again!






IPB skins by Skinbox
Page loaded in: 1.001 seconds