Jump to content

Photo

NVSE with enplczru version


  • Please log in to reply
12 replies to this topic

#1
mpr444

mpr444

    Newbie

  • Supporter
  • Pip
  • 15 posts

Hi, I have enplczru version of the game and I am trying to run the game but I get that steamappid error (65432) I created shortcut and placed -SteamAppId 22490 as launch parameter but I got error saying "Couldn´t read arguments." Now I am stuck. I tried to look for solutions but it looks like this solution works only for FNV4GB.exe. Any help guys? :sad: I bought the version with all DLC and now this happens...

I´ve spent the past hour searching on the internet for solution and I haven´t found anything.


Edited by mpr444, 19 August 2015 - 06:46 PM.


#2
Rabbit 51

Rabbit 51

    If there are no cats in Heaven then I don't want to go.

  • Premium Member
  • 4,022 posts

Forgive me, but what is a "enplczru version"? I've never heard of it. It would help in troubleshooting your issues.

 

 

Rabbit



#3
mpr444

mpr444

    Newbie

  • Supporter
  • Pip
  • 15 posts

Forgive me, but what is a "enplczru version"? I've never heard of it. It would help in troubleshooting your issues.

 
Rabbit

 It's version for czech republic, poland, hungary and slovakia. It's like "different version" of the game only for this region. It's got different appID or how it's called than rest of the world. And that appID is the problem. NVSE tries to load fallout new vegas with appID that rest of the world has. It refuses to work because the appID doesn't match.

#4
Rabbit 51

Rabbit 51

    If there are no cats in Heaven then I don't want to go.

  • Premium Member
  • 4,022 posts

I'm sorry that I can't help you with that, but I do appreciate the explanation. I consider myself much the wiser now. Best wishes in getting an answer to your problem.

 

 

Rabbit



#5
mpr444

mpr444

    Newbie

  • Supporter
  • Pip
  • 15 posts
Yeah... Thanks for trying to help :)

Edited by mpr444, 19 August 2015 - 11:11 PM.


#6
Rencer

Rencer

    Journeyman

  • Members
  • Pip
  • 30 posts

Does anybody find a solution tho this problem?

 

Or we, who live in czech republic,hungary,poland,slovakia,russia are doomed and can't use NVSE mods ever?

 

I bought the DVD version of the Fallout New Vegas Ultimate Edition, in hope that maybe that is a STANDALONE version, that not require Steam. Just to find out, still need the stupid Steam to run the game! :verymad: :wallbash:

 

To be honest, guys, I NEVER ABLE TO PLAY FALLOUT NEW VEGAS, because it is so buggy without mods that fix those bugs!

Literally every few minutes the game crash!

I tried to run the game in WindowsXP 32bit, under Windows 7 64bit. Alwayst the same. Nonstop crashing...

Now I tried run the game under Linux with Wine, the result is the same. Unmodded game runs, but frequent crashes make it impossible to play and enjoy, I always ended up, after many desperate hours of trying to play the game, to ragequit and delete it.

 

It's not that funny when you own a game for years and never able to play it through!

My all time favourite game is Fallout.

I own all epidodes of the Fallout series. (Exept F4, I'm waiting for GOTY or similar editon.)

I played all the games when they fresh and new. I played all the previous series many-many-many times, I even still playing a F1 and 2 playthrough that I started early at 2016. I can't even tell how many times I go through F3, both vanilla and with mods.

I even own the whole Elder Scrolls series, and I played so much with Skyrim, and that game is working perfectly with mods.

Just this one, the FNV, that is don't want to work.

 

Im so sad now, please, someone help!

I really hope that someone, finally, can provide us a solution, that WORKS.

Please, if someone know how to run NVSE whit this Eastern European version, please, POST IT HERE.

 

Thx.



#7
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 6,392 posts

That error is not specific to that regional version.  It means you don't have the "Steam Client" (which is independent of the actual game) running.  See the "Issue: Application load error(s)" entry of the "Fallout NV Mod Conflict Troubleshooting" guide.

 

If you still believe the problem is related to having an "enplczru version", please give the complete path where you have the game installed.  Most of those who try to help here don't have that regional version and need the information to craft a solution.

 

In addition it helps to know which version of Windows (7, 8, 10, etc.) you are running.  And FNV is a 32-bit game, so you need to have any required libraries or drivers (like DirectX 9) installed include 32-bit versions as well.

 

-Dubious-


Edited by dubiousintent, 09 February 2017 - 10:29 PM.


#8
Rencer

Rencer

    Journeyman

  • Members
  • Pip
  • 30 posts

Thanks, dubiousintent, but what you linked not solve the problem.

I always set those parameters in any Gamebryo-engine based  games, I already done those changes after I install any game that using that, but those not fix the problem.

 

Like I write in my post: "Now I tried to run the game under Linux with Wine..." Maybe you missed it.

So, I try to run the game under Linux with Wine, namely; Manjaro Linux with a pure 32bit Wine installation, so it is already running under a full 32bit enviroment, because I know that the Fallout games are 32bit applications.(exept F4) So thats not an issue, I already run it under pure 32bit.

 

Since I wrote my post, I spent countless hours to try out everything that I find to fix this "P:0000065432" problem with NVSE, but still no luck.

Only positive thing is, I managed to configure and set up Wine (lot of hours of work, installing different DLLs, make custom changes in Wine, etc) to be able to run the game fine.

Now I can run New Vegas with lot of mods and I can play few hours in a row, without crashing!!!

 

BUT the real problem is still not solved, NVSE still not working.

 

Why I still believe the problem is with the enplczru version? Because all of those posts around the internet, that marked as solved the problem are all using the "normal" version of the game. And all of those who can't fix this problem, are using this regional version.

(I come to this conclusion after many days, yes literally many days of reading countless forums, pages, etc.)

So it's really looks like that the New Vegas Script Extender have problem with this regional version, because other versions seems to not have this problem, or can be fixed using one of those numerous solutions.

And it's also clear, that this thing is not releated to WIne, because even on the offical Wine page of this game, you can find posts that are writing about runnig NVSE fine.

 

Or what you think? What may be the problem?

 

You asked for the path to the game.

 

It's in "C:\Program Files\Steam\steamapps\common\Fallout New Vegas enplczru"

The game is installed from the two DVDs and Steam intalled with it too, they are the default installation folders.



#9
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 6,392 posts

First of all, that default Steam install path to the "C:\Program Files" folder tree is a problem.  Steam now recognizes that it is and provides instructions on how to move it's games from there.  Please read the article "Installing games on Windows Vista+" (link in my signature) on why this is a problem, the link to the official Steam instructions, and some tips on moving your Steam games elsewhere.  That one step (painful though it is) will solve or prevent many strange problems.

 

When you move the game, consider changing the name of the install folder to just "Fallout New Vegas" using the "custom install" option (if available.  It's been too long for me to recall).  However, I have no idea if this will cause problems later on.  It was one of the "fixes" others found successful at least initially to get NVSE to load.  I recommend trying the following first.

 

Did you come across and try this solution?

 

If anyone comes across this post in the future; I had the same problem when using the 4 GB patch in combination with NVSE. My issue was the target link appid didn't match my actual steam appid (most likely due to me having the NV ultimate edition).

Here's how to fix:

  1. Right click your New Vegas game in steam, and create a shortcut to desktop.

  2. Right click the desktop shortcut and open properties

  3. It should say something like steam://rungameid/22380, copy that last number, that is the game's steam AppID

  4. Right click the 4GB shortcut, open properties

  5. In the Target text box, change the number in -SteamAppId 22380 to your actual steam app ID number.

 

You say in the original post that your AppID is "22490".  Please verify that is the case as described in these instructions and use the one from the original game shortcut (assuming that works without NVSE) in your shortcut properties of the FNV4GB launcher.  Note that because the path to your game contains embedded spaces, the entire path needs to be placed within quotation marks (i.e. "<path>") everywhere it is used in the shortcut link.  The AppID parameter goes outside of the quotes, on the "target" property line ... as in ("E:\Games\SteamLibrary\steamapps\common\Fallout New Vegas\fnv4gb.exe" -SteamAppID 22490); without the parentheses "()".

 

As you have followed the instructions on enabling the "game error log", please check the "nvse.log" in the game root folder ("..\steamapps\common\Fallout New Vegas enplczru").  It should start with lines similar to:

 

NVSE runtime: initialize (version = 5.0.3 040020D0 01D222C4D4C76D4F)
imagebase = 00400000
fallout root = E:\Games\SteamLibrary\steamapps\common\Fallout New Vegas\
config path = E:\Games\SteamLibrary\steamapps\common\Fallout New Vegas\Data\NVSE\nvse_config.ini
plugin directory = E:\Games\SteamLibrary\steamapps\common\Fallout New Vegas\Data\NVSE\Plugins\
checking plugin E:\Games\SteamLibrary\steamapps\common\Fallout New Vegas\Data\NVSE\Plugins\\jip_nvse.dll
 

If it is not present, then post the "nvse_steam_loader.log" here in "Spoiler" tags. please.  If none of those exist, look for a "falloutnv_error.log" file and check it for "Error:" lines.

 

-Dubious-


Edited by dubiousintent, 18 February 2017 - 01:07 AM.


#10
sanassar

sanassar

    Stranger

  • Supporter
  • Pip
  • 2 posts

Privet, Ahoj and Dzen dobry to you my man,

 

I managed to get my enplczru with the "application error P:0000065432" and "couldn't read arguments" errors working. Check the attached picture for some visual info as you go along the steps. You'll know what each is after you reach the step.

 

This is what I did and I have no idea which one of these steps fixed it but there is no harm in doing all of these, please bear with me:

 

Install NVSE first by following the instructions at http://nvse.silverlock.org/

 

This part is only for the normal people, like me, who do not have Fallout NV installed in the default directory where windows is installed  - C:\. If you are not normal and have it installed in C:\ - ignore this step. Also bear in mind that if you are not normal and have the game in C:\ but the folder's name is Fallout New Vegas enplczru, you should do this as well!!

  1. I went to C:\Program Files (x86)\ and created a folder called "Steam" and in it a folder called "SteamApps" and in it a folder called "common". So the whole path looks like this now - C:\Program Files (x86)\Steam\SteamApps\common
  2. I opened Command Prompt and wrote this - cd c:\program files (x86)\steam\steamapps\common - which basically navigates Command Prompt to the file you created
  3. Then I typed in the following -> mklink /d "Fallout New Vegas" "Your full Fallout NV enplczru directory" - mine looks like this - D:\Games\Steam\SteamApps\common\Fallout New Vegas enplczru so my command line looked like this -> mklink /d "Fallout New Vegas" "D:\Games\Steam\SteamApps\common\Fallout New Vegas enplczru"
  4. To check if this worked you now must have a Fallout New Vegas folder in your C:\Program Files (x86)\Steam\SteamApps\common with a little arrow on it. This is a symbolic link. It means any program looking for Fallout New Vegas in C:\Program Files (x86)\Steam\SteamApps\common will find it, but the folder itself will be located on another drive, which is cool.

 

The second part is about getting NVSE to load properly. For this I only managed to do it through the "4GB Fallout New Vegas - Updated" mod. This is a tool that let's you load Fallout New Vegas with lots of Mods and Texture Packs without getting crashes. It sets a 4GB Virtual Memory Address Space for the game to use, hence its name.

 

  1. So go to - https://www.nexusmods.com/newvegas/mods/55061/
  2. Download and install the mod, either by using Vortex (Nexus Mod Manager) or manually - just read the instructions
  3. Then go to the mod folder - mine is at "D:\Games\Steam\steamapps\common\Fallout New Vegas enplczru\Mods\FNV4GB-55061-1-9\FNV4GB-1-9"
  4. Create a shortcut of "fnv4gb.exe" either on your desktop or the start menu
  5. Right click the shortcut and add this -SteamAppId 22490 at the end of the Target: field - so mine looks like this -> "D:\Games\Steam\steamapps\common\Fallout New Vegas enplczru\Mods\FNV4GB-55061-1-9\FNV4GB-1-9\fnv4gb.exe" -SteamAppId 22490

You are done!

 

Now if you want to run the game:

  1. Make sure that Steam is running
  2. Start the game using the shortcut you created and modified in the previous step.
  3. TADAA!

If you want to check whether the NVSE works just press the " ` " command line key in the game main menu and type getNVSEversion. You should get a version number. Mine is 5.

 

This is literally my first ever post on this site. Nice.

Attached Files

  • Attached File  001.png   66.2KB   0 downloads

Edited by sanassar, 26 October 2018 - 10:56 PM.





Page loaded in: 0.825 seconds