Jump to content

Photo

I fixed the NPC voices cutting out issue! YUSSSS!


  • Please log in to reply
31 replies to this topic

#1
rcavanah

rcavanah

    Enthusiast

  • Members
  • PipPip
  • 203 posts
Hey guys,

It's been months since this problem started, and I haven't found any concrete solution online: it's the bug where you walk around an NPC as they talk to you, and in certain positions, their dialogue cuts in and out. I wish I had a handy patch, but it seems to be a deep-seated problem, so there probably isn't a way that a patch could fix it... so for those with the same audio options as me, perhaps this will fix your problems.

I read a post on the Steam forums that suggested that most people who experience this have a Realtek sound card, and are playing in stereo... and both were true of me. I was messing around in my Windows 7 "speakers properties" (search: "Manage Audio Devices," then open the active speakers' properties). Under the "enhancements" tab, I clicked something called "Virtual Surround," which says it encodes surround audio for transfer as stereo output to receivers with a matrix decoder. It sounded similar to the problem; the guy on the other forum pointed out that perhaps Skyrim was always trying to output 5.1 audio, so at certain angles, the audio doesn't have a proper rear speaker to output through.

So, I checked the option, then booted up Skyrim, and I haven't had a single voice cut out since. In fact, I've noticed much more dimension in the sound, and I hear a clean transition from speaker to speaker as I circle wildly around talking NPC's. Never noticed that before, and I think it's because there was no transition... it just cut out.

Hopefully someone else can benefit from this experience! :D

#2
Rooker75

Rooker75

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,065 posts
I've been having the same problem ever since the 1.3 patch, but that sound card option is already checked for me.

#3
bofadeez

bofadeez

    Newbie

  • Premium Member
  • 12 posts

I realize this is two months old but I wanted to say this fixed the problem for me. I have a Razer Megalodon 7.1 USB headset, not a Realtek sound card, but I had the same annoying angle-dependent cutting out. Talking to an NPC and then walking away while he's still talking would almost always trigger it. For me, the relevant option was called "Speaker Fill," but the description was more or less what you described.

 

Thanks, it's really nice to have this annoying problem resolved.



#4
jefftimlin2

jefftimlin2

    Stranger

  • Members
  • Pip
  • 6 posts

Thanks heaps, this also fixed it for me too. I do have a realtek card but I didn't have the "Virtual Surround" option. For me, I went to the Realtek HD Audio Manager icon in the system tray, changed to 5.1 speaker configuration, and ticked the "Speaker Fill" option, and disabled all the "optional speakers". Not sure which of these things fixed it, but it sounds just fine now. Thanks again :)



#5
bellestarr

bellestarr

    Old hand

  • Members
  • PipPipPip
  • 520 posts

I am so glad i found this thread, ive had this problem forever and it really does drive me nuts. I copied the advice above me (thanks jefftimlin2!!) and ive had no more cutting out on dialogue .... thanks guys, thought i was the only one!  :)



#6
daz7887

daz7887

    Stranger

  • Members
  • Pip
  • 1 posts

For anyone with a Realtek sound card who is still having this problem, I just thought I'd share what worked for me.

 

I tried all of the above things and every other suggestion I could find, and none of it worked. I was looking up surround headphones at the time, and one review pointed out that they are just standard headphones with special drivers, and you can easily get software that does the same thing. When I installed one, I noticed it created its own playback device, seperate from the Realtek one. So I thought maybe if you bypass the Realtek driver altogether, it might fix this problem. And it did.

 

 

- Go to Sound in Control Panel and disable any device that has Realtek in its name. Also go to Add/Remove Programs and uninstall the Realtek drivers from there. (You can always download them again later if this doesn't work).

 

- Search for "razer surround", click on the first result, download and install.

 

 

You MUST do it in the above order or it won't work. Razer Surround is the first one I found; I'm not necessarily recommending it over others. It's free until the end of 2013 but remember to go back and DONATE if it works! If you have any problems, make Razer Surround Audio Controller is selected as the default playback device, and that there are no Realtek devices in the list.

 

Hope this helps someone out there.



#7
luckysoldier13

luckysoldier13

    Enthusiast

  • Supporter
  • PipPip
  • 109 posts

For anyone with a Realtek sound card who is still having this problem, I just thought I'd share what worked for me.

 

I tried all of the above things and every other suggestion I could find, and none of it worked. I was looking up surround headphones at the time, and one review pointed out that they are just standard headphones with special drivers, and you can easily get software that does the same thing. When I installed one, I noticed it created its own playback device, seperate from the Realtek one. So I thought maybe if you bypass the Realtek driver altogether, it might fix this problem. And it did.

 

 

- Go to Sound in Control Panel and disable any device that has Realtek in its name. Also go to Add/Remove Programs and uninstall the Realtek drivers from there. (You can always download them again later if this doesn't work).

 

- Search for "razer surround", click on the first result, download and install.

 

 

You MUST do it in the above order or it won't work. Razer Surround is the first one I found; I'm not necessarily recommending it over others. It's free until the end of 2013 but remember to go back and DONATE if it works! If you have any problems, make Razer Surround Audio Controller is selected as the default playback device, and that there are no Realtek devices in the list.

 

Hope this helps someone out there.

I know you posted this a while ago, but id just like to give some feedback anyways. Thank you so much for pointing me towards Razer! My game sounds amazing now without the annoying cut outs that have plagued me since I got Skyrim, and everything sounds a thousand times better!



#8
Bizzquik

Bizzquik

    Old hand

  • Premium Member
  • 574 posts

For anyone with a Realtek sound card who is still having this problem, I just thought I'd share what worked for me.

 

I tried all of the above things and every other suggestion I could find, and none of it worked. I was looking up surround headphones at the time, and one review pointed out that they are just standard headphones with special drivers, and you can easily get software that does the same thing. When I installed one, I noticed it created its own playback device, seperate from the Realtek one. So I thought maybe if you bypass the Realtek driver altogether, it might fix this problem. And it did.

 

 

- Go to Sound in Control Panel and disable any device that has Realtek in its name. Also go to Add/Remove Programs and uninstall the Realtek drivers from there. (You can always download them again later if this doesn't work).

 

 

I know you posted this a while ago, but id just like to give some feedback anyways. Thank you so much for pointing me towards Razer! My game sounds amazing now without the annoying cut outs that have plagued me since I got Skyrim, and everything sounds a thousand times better!

 

Just wanted to thank you both and say that uninstalling the Realtek drivers appears to have fixed my problem.  I had heard that simply restarting the computer can provide a temporary fix for the dialogue cutting out, but I really think uninstalling Realtek and making my computer use my sound card's audio for everything (with absolutely no contribution from the on-board Realtek audio) did the trick.  Interesting that simply disabling the Realtek audio did not work - it actually had to be uninstalled.



#9
rolloLG

rolloLG

    Hexaae

  • Supporter
  • PipPipPipPip
  • 1,616 posts

I've been playing Skyrim for years with this bug.

Thanks to good old Realtek HD Audio R250 (6.0.1.6151) for my MSI GX660 + Razer drivers https://www.razerzone.com/surround I can finally say bye bye to all those annoying audio cuttings! They also improve 3D space perception a lot and make all sounds clearer and distinct.

Didn't know Razer, thank you all guys! :smile:


Edited by rolloLG, 24 March 2014 - 05:13 PM.


#10
camaro_69_327

camaro_69_327

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,100 posts

I have the cut-out on occasion...but i don't have a realtek anything. I DO have 5.1 and c-media. and every once in a while i will turn while an NPC is talking and it just cuts out. But the Sound is great overall, and having the sound travel in a 360 as i spin, is totally immerse so i cant complain.

 

   ASUS Xonar Essence STX to a 1000 W z-5500 = OMG






Page loaded in: 0.994 seconds