Jump to content

Photo

NifSkope Infinite recursive link, failed to load block after blender edit

nifskope blender

  • Please log in to reply
2 replies to this topic

#1
F3LLA22

F3LLA22

    Journeyman

  • Members
  • Pip
  • 36 posts

Tried to edit a weapon nif in blender. Got it done, and exported it as a nif file. When trying to open the file in NifSkope I get two error windows pop up saying

 

Warnings were generated while reading NIF file.

infinite recursive link construct detected 8 -> 0

infinite recursive link construct detected 8 -> 8

infinite recursive link construct detected 8 -> 7

 

the second window says:

 

The NIF file could not be read. See Details for more information. 

 

failed to load block number 9 (NiTriShapeData) previous block was NiSourceTexture

Failed to load C:/Users/User1/Downloads/G36K.nif

 

What am I doing wrong? for context, in blender I just separated a part of a mesh and turned it into a separate mesh.



#2
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 8,119 posts

I'm not a modeller, but I interpret that problem to be telling you that you lost the "NiTriShapeData" from the original mesh when you separated out the part you wanted.  The resulting NIF file is thus invalid and can't be read.

 

You might want to take a look at "TIP Mashing Meshes" and the other tips in the "Custom items" and "Weapons" sections of the wiki "Getting started creating mods using GECK" article.

 

-Dubious-



#3
M48A5

M48A5

    Resident poster

  • Members
  • PipPipPipPipPip
  • 8,640 posts

What you can do is import into blender the .nif file and then remove everything you don't want. 

 

When you export it, give the file a unique name (A) you can remember.

 

Import a second copy of the complete armor and remove everything that will be replaced by the first armor you changed. 

 

Give the file a unique name (B) when you export it.

 

This will give you two .nif files with the textures correctly mapped.  You will have to open each file in NifSkope and apply the correct shader settings.


Edited by M48A5, 26 June 2020 - 02:10 PM.






Also tagged with one or more of these keywords: nifskope, blender

Page loaded in: 1.165 seconds