Jump to content

3DS Max & NIFskope - textures and parts of mesh missing in-game


Recommended Posts

Hello all!

Yes, I am somewhat of a newbie with this whole "making custom armors" Thing. But, I have been attempting to reverse engineer (and legitimately learn how to model armors or edit vanilla ones) BOUND ARMORS (single suit mesh, or full body meshes)!


So far, I've been unsuccessful in getting it to show completely in game! As you can see by the attachment below, the full suit is complete, has alpha properties on it, bslightingshader properties for the textures, and the parts I added are all skin wrapped to the vanilla skyrim skeleton parts (greaves part of the mesh wrapped to the "malefoot.nif" and gloves are wrapped to "malehand.nif" while the cuirass part are wrapped to the "malebody.nif" ...


Now, I've followed this set of tutorials by Nightasy (I watched 1-40 in hopes of figuring out how to make multiple parts into one mesh, but he does not cover that):


Anyway. The main problem is that in Creation Kit (And in game), my custom armor doesn't show the gloves or the cuirass part at ALL. No model, no textures. But it appears fine in the NIFskope as seen below:




But the pauldrons, cuirass, and gloves are invisible as soon as I attach the textures to the armor and put it in creation kit! Is this anything to do with the nifskope plugin, an error I made in 3DS, or an error I made in nifskope?

*I only imported the skeleton once

*I reskinned and re-added the bslighting shader properties to the model inside 3DS.

*I set all of the pieces of the armor to the "decapitated head" slot (slot 50 in CK), except gloves are slot 51 (decapitated neck).


Was I supposed to unrap the UV even though I wanted the default textures? I didn't touch the UV settings in 3DS at all, but I didn't think I would need to since I didn't want new textures... Aside from that I followed all of his exact steps of his tutorials flawlessly. But clearly my situation is... complicated.



If needed I could always post my nif model in a zip folder if anyone can troubleshoot for me. I felt as though I got everything covered. Additionally, The UV map number in nifskope is set to 1 because Foster XBL's setting is also set to 1 and it still works. Setting it to 4097, and facing the mesh normals does nothing to help. There is either a problem with the programs or I made a minor mistake somewhere along the way that I overlooked. I sure as HELL am not starting this model over again, I deleted SO many unnecessary vertices and faces for my mod... haha


I appreciate your time, and if any experienced armor modelling users (with 3DS max) have seen this before and know what I did wrong, I would appreciate a guide in the right direction or even lending a hand in fixing my current mesh (it should still be salvageable! Otherwise I might freak out. I've spent almost a MONTH in almost all my free time trying to get this to work finally and I can see why people make careers out of this lol. If you want a copy of my model and you fix it, you're going to get 80% of the credit for it since I can't fix it on my own most likely... ~_~

Edited by GraysonTheWolf
Link to comment
Share on other sites

Yeah, I know I'm not supposed to double post but I needed to add another picture of the creation kit screenshot.


This is how it looks in creation kit. Only the mesh, and the emissive color show. No tetures even.




Looking forward to the replies! :D



Thank you all again!

Link to comment
Share on other sites

So I clicked face meshes in nifskop for every NItrishape that I had.

I didn't face the meshes in 3DS Max. And I didn't UV unwrap in 3DS either.

I wanted the original textures. Do I need to UV unwrap the meshes even though I'm using vanilla textures?

I deleted some parts of the meshes so I knew that I had to reskin the parts and add new bsdismemberskin nodes.


My steps simplified that I followed:
1) import cuirass W/O skeleton box checked
2) import gloves W/O skeleton--
3) import boots W/O skeleton--
4) import malebody W/skeleton, then import foot and hands W/O skeleton--

(so I imported the skeleton only once. I don't think the skeleton is problem in other words)
5) deleted parts of the polygons and vertices I didn't like on each editable mesh
6) delete old skin and dismemberskin nodes in editing window
7) smooth --> 2
8.) skin wrap each part to the proper body part (boots wrapped to feet, gloves wrapped to hands, etc)
9) add bsdismemberskin data and delete "skin wrap" node after the the "skin" node is made.
10) highlight the greaves, cuirass, and pauldrons to slot 50 (skyrim, decapitate head)
11) highlight the gloves to slot 51 (skyrim, decapitate neck)
12) export file NIF with "welds" set to 0.0
13) open NIFskope and reroute the proper texture paths and add alpha shader properties to each part.

14) create new objects in Creation kit (this is where I only saw the greaves/boots of my armor, with no textures, just the emissive colors I added)


So because I know CK like the back of my hand now, I know that the mistakes are definitely in the 3DS or NIFskope part of my process...

Edited by GraysonTheWolf
Link to comment
Share on other sites

i can't correct your steps because i dont know how to make armors :tongue:

but in c4d i got the same thing. when my meshes aren't faced correctly they are blue. and in mudbox and in nifskope they are not visible.


check this :wink:

Edited by 7evenforce
Link to comment
Share on other sites

If you have added new geometry to the game mesh, i.e added new vertices and polygons, you will need to uv map the model again as the new polygons won't be mapped correctly.


Also, recalling the last time I looked at the meshes, your nifs with your weighted meshes should be split up into torso, hands, boots and helmet. So you shouldn't have say the hands in the same nif as the torso.

Edited by The SH0CKER
Link to comment
Share on other sites

UPDATE: So the meshes are showing up now. Now the textures are just not showing up in the creation kit and I'm getting a really really dark (basically black or dark purple) color all over my armor pieces. Somewhere between NIFskope and Creation kit, the textures are not showing up. I'm using the 1.1.0 rc4 version of nifskope which is used by a lot of modders with the least complaints. Just for some reason, my models are very dark and the shininess depends on whether I add a texture to my cubemap texture path in the BSLightingShaderProperties-->BSSHaderTextureSet.


@ The SH0CKER:

no no no, this is a bound armors mod I'm makin'. :tongue:

The hand, foot, and torso parts are part of one nif file. This saves armor slots.

It works for me in game without textures, I've correctly skinned each part to each body part so the weights are fine.

Each part in the nif files shows up as a node. The glass cuirass is actually two pieces (if you open up the nif file),

My bound armor model that I've made is just 4 pieces now instead of 2.


So now if anyone knows why the textures are not showing up at all, that would be awesome ._.

7evenforce and I have the same problem using 2 different modelling programs (he is using C4D, I'm using 3DS Max 2012).

Maybe this NIFskope 1.1.0 rc4 just sucks? haha




It's working! My mod works :D

Because I used vanilla textures, my fix was to just copy the BSLightingShaderProperties node from the original mesh (ie "glass gauntlets" to the new mesh glass gauntlets node! I didn't change the name so the node copied over perfectly since it thought it was still the same "parent")


In other words.... This thread is solved! ^o^

Here's my model in Creation kit:





Edited by GraysonTheWolf
Link to comment
Share on other sites

Well the issue is that you have custom textures. I'm not sure that it would work for yours. Mine worked because I "cheated" nifskope. Here's the tutorial that I followed:




His tutorial series are PERFECT. But the issue is, you don't have an original model that you're take the texture from (to copy to the new model).

Which is the only reason why it worked for me. I copied the BSLightingShader node thing from a GLASS armor nif file, and it fixed my modified version since it's the same shape/UV, just deleted some parts and combined the meshes into one model. It was much easier to combine in 3DS than when I tried combining models in Cinema 4D. And Nightasy goes in FULL depth of everything you need to know for both vanilla and custom armors with 3DS Max (2012 student version, which is free if you sign up to Autodesk education center). Cinema 4D was fine with the new weapons I tried making, but I didn't have a good texture to paint with, and you end up using mudbox anyway (another autodesk software), so might as well get the 3-year free student license with 3DS Max. haha :p




So back on topic:

No. of UV's is set to 4097?

Meshes are faced normals?

did you check the BSLightingShader properties? Are your textures in the right order?

Here's a useful thread, idk if it'll help, but it's useful nonetheless :P




Also, in that section, is your shader properties, "Shader Type" (at the top of the details box) set to 0 or 1? I think you need it to be set to 1.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...