Jump to content

Photo

How do and should I update?!?


  • Please log in to reply
13 replies to this topic

#1
entropiachrome

entropiachrome

    Enthusiast

  • Members
  • PipPip
  • 235 posts
Hey all, (First time TES and STEAM user...)

I've been using Skyrim for 2 months now, and have no idea how to update the game, or even if I should... I see grumblings here and there about "bad patches", and the game seems to be running alright for me as it is now.

This past week I just figured out how to add mods through Nexus, and I'm concerned updating will mess up all my mods. That said, SKSE keeps saying I need the latest version of the game to work correctly, and SkyUI and Catagorized Favorites Menu are giving me mild issues...


Thanks in advance for responses, your advice is appreciated!

#2
Dukkah

Dukkah

    Enthusiast

  • Members
  • PipPip
  • 132 posts
STEAM should update automatically, unless you turned that function off. Not sure what's wrong with SKSE though.

#3
ian gray

ian gray

    Enthusiast

  • Premium Member
  • 149 posts

STEAM should update automatically, unless you turned that function off. Not sure what's wrong with SKSE though.

SKSE and skyui wont work with the new 1.4.21 patch. You will have to wait for the modders to update their work again. Chances are your game has updated if they're not working

#4
nosisab

nosisab

    The old faithful

  • Premium Member
  • 3,071 posts
verify the version of Skyrim you are now, to it enter the game normally without using SKSE, press Esc key and the version will be printed on the bottom left of the menu. Probably it will be 1.3.10.00 and them the correct SKSE version is that first in their page 1.04.03 (for the last stable patch).

To be able to try the beta patches you need to explicitly change it into the Steam "Settings", "Beta Participation: Skyrim beta", what at this point, if you are not yet you may rather wait a bit more for the incoming stable patch.
If is already at the 1.4.21.04, SKSE indeed will not work till being updated (again) for it is tightly tied with the game version. Even then you can still play without SKSE, remove it's files and disable the mods using it (this is only for the case the game is already in beta).

Edit: if you already installed SKSE version 1.4.7 is advisable to remove it's files before installing 1,4.3. May be unnecessary but beyond helping to keep the folder clean it is the secure procedure always and valid to mods too. SKSE files all begin with skse...

Edited by nosisab, 30 January 2012 - 10:28 PM.


#5
entropiachrome

entropiachrome

    Enthusiast

  • Members
  • PipPip
  • 235 posts


STEAM should update automatically, unless you turned that function off. Not sure what's wrong with SKSE though.

SKSE and skyui wont work with the new 1.4.21 patch. You will have to wait for the modders to update their work again. Chances are your game has updated if they're not working



OK, thanks for the responses...

I'd really like to have the "Equipment Sets" function on the favorites menu, I'll chack again and see if maybe I did something wrong installing SKSE...

If updates are done automatically through Steam, then I guess I'm updated. :confused:

#6
entropiachrome

entropiachrome

    Enthusiast

  • Members
  • PipPip
  • 235 posts

verify the version of Skyrim you are now, to it enter the game normally without using SKSE, press Esc key and the version will be printed on the bottom left of the menu. Probably it will be 1.3.10.00 and them the correct SKSE version is that first in their page 1.04.03 (for the last stable patch).



It's showing version as 1.3.10.00

Trying to load the game with the SKSE loader says "Please update to the latest version of Skyrim" and then closes.

SkyUI and Catagorized Favorites menu still have issues.

#7
nosisab

nosisab

    The old faithful

  • Premium Member
  • 3,071 posts
This is because you are using SKSE version 1.04.07... you need 1.04.03 for the "stable" patch that is that 1.3.10

The same may be necessary for those mods if you installed the last version. Notice you need the "stable" version, that one stating is for 1.3.10

Be prepared for the game stopping again as soon as the new stable 1.4 is out.

Edited by nosisab, 30 January 2012 - 10:34 PM.


#8
entropiachrome

entropiachrome

    Enthusiast

  • Members
  • PipPip
  • 235 posts

This is because you are using SKSE version 1.04.07... you need 1.04.03 for the "stable" patch that is that 1.3.10



Hmmm... I did have the other "beta" SKSE installed, so I tried the 1.04.03... the SKSE loader boots up as if it's gonna start the game, then shuts down.

:verymad:

Any ideas what I'm doing wrong? The SKSE files are all copy/pasted into the Steam>SteamApps>common>Skyrim folder...

#9
ian gray

ian gray

    Enthusiast

  • Premium Member
  • 149 posts
I'm not sure why its not working. Try making a backup copy of your 2 ini files in your skyrim documents folder, then delete them. Restart the game with the skse launcher which will create 2 new untarnished ini files and see if that works. It will reset your graphics settings but you can always replace the copies of your ini files back in again if the game still wont run.

#10
entropiachrome

entropiachrome

    Enthusiast

  • Members
  • PipPip
  • 235 posts

I'm not sure why its not working. Try making a backup copy of your 2 ini files in your skyrim documents folder, then delete them. Restart the game with the skse launcher which will create 2 new untarnished ini files and see if that works. It will reset your graphics settings but you can always replace the copies of your ini files back in again if the game still wont run.



I just now tried that... SKSE launcher made a new "Skyrim" ini but still didn't launch.

Thanks for the help, I give up for now. o_O




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.925 seconds