Jump to content

Photo

Pixelated Rainbow Textures on Mod Weapons

weapon texture rainbow glitch

  • Please log in to reply
3 replies to this topic

#1
CatsWithMachineGuns

CatsWithMachineGuns

    Regular

  • Members
  • PipPip
  • 64 posts

Hello fine people of Nexus, I've got a little problem on my hands here.

 

I have tried googling the issue, but can't seem to find any similar thread, post, comment, or fix that matches the exact predicament I have here.

 

I'm trying a new playthrough of Fallout 4, but this time with the addition of some lore friendly weapons that I'd like to try out this time around. The issue is these newly-added mod weapons seem to have this issue of randomly having their textures become rainbow and pixelated with no discernable pattern I can pinpoint and work around. I should note that unlike the results google shows from other forums and issues, this does NOT affect vanilla assets from the game. It does not occur with regular weapons, characters, or the environment. It strictly happens with community-created weapons and community-created weapons alone, seemingly at random.

 

Sometime they fix themselves when entering a new cell or loading screen, other times they're working fine until entering a new cell or loading screen. I cannot seem to keep an arsenal of newly added weapons without at least a random handful of them at any given moment looking like the picture below.

 

I am only using a small handful of mods (<20) with NMM and these new weapons make up the bulk of them, but unfortunately I can't really enjoy using them because their textures have a tendency to turn into cyborg unicorn vomit, which while definitely magical, is not quite what I was looking for in this particular Fallout playthrough.

 

Any help appreciated!

Attached Files


Edited by CatsWithMachineGuns, 23 November 2021 - 01:33 AM.


#2
CatsWithMachineGuns

CatsWithMachineGuns

    Regular

  • Members
  • PipPip
  • 64 posts

Has nobody else ever had this problem before? I should add that I have it set up so that the files are packed into .ba2 file format as opposed to loading a bazillion loose textures directly from the data/textures folder. I'm just curious as to whether or not this is an issue only I am facing or if others also have this error, and if so, I'm wondering how on Earth they overcame it.



#3
HeyYou

HeyYou

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 12,255 posts

That IS bizarre. I haven't seen that one before.... Are you using any ENB, or Reshade? Packing the files into archives should actually HELP performance, not screw it up.



#4
CatsWithMachineGuns

CatsWithMachineGuns

    Regular

  • Members
  • PipPip
  • 64 posts

Hi and thanks for the reply!

 

I am not using any sort of ENB or Reshade, my game is practically vanilla in terms of how few mods I actually have, which made the issue extra puzzling. And I must stress again, that this would happen exclusively on custom weapons, not on characters, outfits, the environment, etc.

 

I believe I have found a solution to the problem though, of course I need to test it one weapon at a time to ensure they all work, but it seems I was merely not carefully investigating the settings in Archive2 for packaging textures. 

 

I tested the alleged fix with a custom assault rifle model (which too had this issue) by fast traveling around the map sporadically, equipping and unequipping it, reloading saves, etc, and it seems to successfully keep its textures intact. So far there have been no rainbow pixels.

 

 

 

So for anyone frantically googling a fix for this issue 4 years from now, try making sure that you're using the proper Archive2 compression settings when packaging your textures into a .ba2 file!


Edited by CatsWithMachineGuns, 28 November 2021 - 07:20 PM.






Also tagged with one or more of these keywords: weapon, texture, rainbow, glitch

IPB skins by Skinbox
Page loaded in: 1.016 seconds