Jump to content

Photo

Adding Glow Maps in Nifskope


  • Please log in to reply
6 replies to this topic

#1
DyingAtheist

DyingAtheist

    Fan

  • Members
  • PipPipPip
  • 298 posts
Hi!
I'm nearly done with a weapon, an Iron Claymore that I'm modding. However, for the life of me I can't seem to figure out how you add the actual glow map in Nifskope!
I've got the model of the Claymore up in Nifskope, it's showing as fully textured and I've set the various properties necessary for the glowmap to actually work. However, I simply can't figure out how to -Add Glowmap- or something.

Anyone who has any advice, it'd be greatly appreciated!

#2
SariDecember

SariDecember

    Soldier of Doomsday

  • Supporter
  • PipPipPipPip
  • 1,549 posts
Hi,

I just added glowmaps to fallout nifs so far, don't know whether there's difference. Try digging through these two tutorials to see if you set up everything right:

http://wiki.tesnexus...hp/Glowmaps_101

http://wiki.tesnexus...o_add_glow_maps

Also make sure you set the Emitmulti in NiMaterialProperty to 1!

Cheeerz *Sari-D

#3
DyingAtheist

DyingAtheist

    Fan

  • Members
  • PipPipPip
  • 298 posts

Hi,

I just added glowmaps to fallout nifs so far, don't know whether there's difference. Try digging through these two tutorials to see if you set up everything right:

http://wiki.tesnexus...hp/Glowmaps_101

http://wiki.tesnexus...o_add_glow_maps

Also make sure you set the Emitmulti in NiMaterialProperty to 1!

Cheeerz *Sari-D


The second one helped a bit; managed to get the glowmap into the "Textures" section of BSShaderTextureSet. However, there's still no effect in-game.
Can't seem to find "Emitmulti", could the fact I haven't changed that to 1 be what's causing the glow to not work?

#4
Ghogiel

Ghogiel

    Resident poster

  • Members
  • PipPipPipPipPip
  • 4,647 posts
you need 'shader type' set 2. It's probably 1. Then tick the shader flag SF_Glow_Map. That should enable the shader for glow maps to work.

emitmulti isn't in the SK shader afaik. The 2 material parameters used to control self illumination are emissive color and emissive saturation. And of course the glow map itself.

#5
DyingAtheist

DyingAtheist

    Fan

  • Members
  • PipPipPip
  • 298 posts

you need 'shader type' set 2. It's probably 1. Then tick the shader flag SF_Glow_Map. That should enable the shader for glow maps to work.

emitmulti isn't in the SK shader afaik. The 2 material parameters used to control self illumination are emissive color and emissive saturation. And of course the glow map itself.


Shader type is set to 2, and I've added SF_Glow_Map to Shader Flags 2. I've also changed emissive colour to a grey and emissive saturation up to 5.
Maybe it's something in the design of my glow map? Or perhaps I'm simply saving the resulting .nif file in the wrong area...

(meshes - meshes - weapons - iron)


UPDATE : To test the latter theory out, I upped the scale of the Claymore in Nifskope to 6x it's original size, then saved the resulting .nif in the same area I have been doing. This didn't affect my in-game sword at all.

Edited by DyingAtheist, 06 February 2012 - 05:29 PM.


#6
Ghogiel

Ghogiel

    Resident poster

  • Members
  • PipPipPipPipPip
  • 4,647 posts
did you collapse the transforms after? mesh>transforms>apply

#7
DyingAtheist

DyingAtheist

    Fan

  • Members
  • PipPipPip
  • 298 posts

did you collapse the transforms after? mesh>transforms>apply


After messing with the scale? Yup. I've just extended my sword over the X axis massively, leading to a rather bizarrely shaped weapon.
When I drag the resulting .nif into meshes-meshes-weapons-iron...there's no change in game.

Edited by DyingAtheist, 06 February 2012 - 06:36 PM.





Page loaded in: 0.771 seconds