Jump to content

Photo

Epic Games Modding - A Techical Solution


109 replies to this topic

#21
rawlez

rawlez

    Stranger

  • Members
  • Pip
  • 1 posts

the cmd file launches the game, but mods still doesn't work?

Edit: It worked with mods when i ran the script :)


Edited by rawlez, 01 February 2021 - 03:57 PM.


#22
Cheesekong

Cheesekong

    Stranger

  • Members
  • Pip
  • 8 posts
old way was working last night but wont anymore and the new way isnt working either keeps saying 
 
[0201/113251:WARNING:resource_bundle_qt.cpp(114)] locale_file_path.empty() for locale  
four times in a debug file

Edit: Nevermind I got it to work one of the mods was causing it not to open

Edited by Cheesekong, 01 February 2021 - 04:46 PM.


#23
dinodan20002

dinodan20002

    Stranger

  • Members
  • Pip
  • 1 posts

I used the premade script and it worked twice then i installed a new mod in frosty and now only origins will open when I run the cmd. What am i doing wrong. The script says game launched but it never launches 



#24
Nakaka

Nakaka

    Newbie

  • Members
  • Pip
  • 19 posts

I used the premade script and it worked twice then i installed a new mod in frosty and now only origins will open when I run the cmd. What am i doing wrong. The script says game launched but it never launches

Sounds like you already know what's causing the problem, but unapply all mods, launch with forsty, then close the game and try launching with the cmd file. Mods can break your game when they're incompatible or become incompatible. Maybe someone more experienced can help you

Also check you have Epic/Origin open, and check whether Epic Games Store says the game's already running


Edited by Nakaka, 01 February 2021 - 10:19 PM.


#25
Babydolls01

Babydolls01

    Stranger

  • Members
  • Pip
  • 4 posts

it work.

can i share this to community in thailand ?

 

ty a lot bro.



#26
Pinballmaster12

Pinballmaster12

    Stranger

  • Members
  • Pip
  • 7 posts

smh I cant even get through the first steps



#27
Pinballmaster12

Pinballmaster12

    Stranger

  • Members
  • Pip
  • 7 posts

there is no point this doesnt even work

 



#28
ThePotatoWhisperer

ThePotatoWhisperer

    Journeyman

  • Members
  • Pip
  • 25 posts

I had my hand at this yesterday and found a solution. This solution assumes you already have Frosty Mod Manager, and have attempted to launch the game with your imported mods. (this creates a necessary "ModData" folder)

Backstory
Recently EA decided to update Origin to require the use of EpicGamesLauncher.exe to launch Battlefront II.
Earlier versions of Origin doesn't need EpicGamesLauncher at all. Although nothing's technically preventing you from using the earlier Origin, you cannot play Battlefront II with friends. With the new version of Origin, Origin launches EALink.exe, which talks to EpicGamesLauncher.exe, and will not carry over the "-datapath" required to load mods.

Solution Part 1 (Optional? See *Note)

  1. Open CMD.exe (from start menu) and go fullscreen so you can see it better
  2. Paste (without quotes): "WMIC path win32_process get Caption,Commandline"
  3. Launch Battlefront II from Epic
  4. Press enter inside CMD.exe
  5. Look for EALink.exe in the list. If you see it, you have all the information you need. Copy the whole line to Word/Notepad for reference. You can copy text from CMD.exe by selecting the text, then right-clicking it.

If you don't see EALink.exe in the list, it isn't running, so you pressed enter too late/early.

Solution Part 2

  1. Open notepad.exe (from start menu) and paste this line of text to it (INCLUDING quotes):
    "[PATH_TO_ORIGIN]\EALink.exe" "link2ea://launchgame/MtMassive?AUTH_PASSWORD=[AUTHPASS]&AUTH_TYPE=exchangecode&epicusername=[EPICUSERNAME]&epicuserid=[EPICUSERID]&epiclocale=en&theme=sws&platform=epic&Hotfix=go& -datapath %22[DATAPATH]%22"
  2. Replace [AUTHPASS], [EPICUSERNAME], and [EPICUSERID] with the information you gathered from CMD.exe earlier.
  3. Replace [DATAPATH] with something like: C:\Games\Origin\STAR WARS Battlefront II\ModData
  4. Replace [PATH_TO_ORIGIN] with something like: C:\Program Files (x86)\Origin
  5. Open another CMD.exe (from start menu)
  6. Paste the notepad's text into CMD.exe (right-click -> paste)
  7. Press enter to launch the game.

*Note: It might be that [EPICUSERNAME] and [EPICUSERID] can be blank, and [AUTHPASS], though necessary, can be 0... epic.

 

Easier Solution

  1. Open Epic & Origin
  2. Open notepad (from start menu) and paste in this line of text (INCLUDING quotes):
    "C:\Program Files (x86)\Origin\EALink.exe" "link2ea://launchgame/MtMassive?AUTH_PASSWORD=0&AUTH_TYPE=exchangecode&epicusername=&epicuserid=&epiclocale=en&theme=sws&platform=epic&Hotfix=go& -datapath %%22DATAPATH%%22"
  3. Replace DATAPATH with something like C:\Program Files (x86)\Origin Games\STAR WARS Battlefront II\ModData
  4. Save the file (to your desktop) as Battlefront.cmd
  5. Double-click Battlefront.cmd to launch the game.

If Origin pops up but the game doesn't open, your DATAPATH is probably wrong. There is no backslash at the end.

For those still having trouble, running this script accomplishes the same thing.


Thanks to Bread for helping me test.

It Worked Finally, thanks soo much my man!!!!

 

Made my own, the game launched but the mods didn't launch. Was losing hope, than checked agin the forum and run yours and now it works!!!!

 

Edit: reading, peole are still having issues, just download his version, it worked for me. 


Edited by ThePotatoWhisperer, 02 February 2021 - 12:14 AM.


#29
Nakaka

Nakaka

    Newbie

  • Members
  • Pip
  • 19 posts

it work.

can i share this to community in thailand ?

 

ty a lot bro.

For sure
 

 

 

smh I cant even get through the first steps

Try skipping to the end and clicking the "this" link, run that after bypassing any antivirus prompts

 


Edited by Nakaka, 02 February 2021 - 01:19 AM.


#30
SoaRRenna

SoaRRenna

    Stranger

  • Members
  • Pip
  • 1 posts

old way was working last night but wont anymore and the new way isnt working either keeps saying 
 
[0201/113251:WARNING:resource_bundle_qt.cpp(114)] locale_file_path.empty() for locale  
four times in a debug file

Edit: Nevermind I got it to work one of the mods was causing it not to open

What mod was it? In case I also have that mod so that I know which one to disable. 





Reply to this topic



  


IPB skins by Skinbox
Page loaded in: 1.272 seconds