Jump to content

DS:PTDE Multiplayer Broken


Recommended Posts

I recently bought Dark Souls: Prepare to Die Edition whilst it was on steam discount. The first thing I did was install DSFix and DSMFix It worked as perfectly as Dark Souls can for the first 50 hours of playtime. I could also play with a friend whenever it was possible, although it would often take around tries of summoning. During my last 4 hours of playtime, however, I have experienced escalating problems with connecting to other players. At first, the only connection issues noticeable were when others tried to invade me. I could walk into the Forest where you join the cat covenant and immediately the doors would turn to fog, but the invasions would fail. About a day after experiencing this, my ability to connect to my friend decreased significantly. It would take around 17 tries or would not work at all.


Because of this, we both got DSCFix and installed it correctly. After installing DSCFix, we would often see each other's blue ghost immediately within proximity. However, we could not see bloodstains or any summons signs. We could watch each other's ghost put summon signs down, but could not see any summon signs.


Because of DSCFix breaking summon signs completely, we both uninstalled it. Now we both have DSFix and DSMFix, which we reinstalled from scratch. However, we still cannot see each other's summon signs or any other summon signs. My friend can see bloodstains and ghosts now, but not summon signs. I cannot see bloodstains or summon signs, but I can see ghosts.


To summarize:

-My connection ability decreased to basically impossible.

-I installed DSCFix.

-Connection ability dropped to ZERO

-Uninstalled DSCFix

-Connection ability still ZERO

-With DSCFix installed and after uninstalling it, I can no longer see summons signs.

-GFWL Ports are forwarded

-Firewall is turned off

-UPnP is enabled

-I cannot be invaded

-I do not know if I can be summoned by anyone other than my friend

-I currently do not have a way to test whether or not I can invade other players (Can't join cat covenant because I attacked the cat, and I don't have access to any red eye orbs)

-I tried without DSFix, DSMFix, or DSCFix installed, and still cannot summon my friend or be invaded


-Whilst DSCFix was installed, I had edited the DSFix.ini to inputchain to DSCFix.dll, and edited DSCFix.ini to chain to DSMFix.dll
-I enabled DSCFix to log to DSCFix.txt, the log recorded DSCFix activating and connecting to my friend, who had also installed DSCFix correctly

-His DSCFix log recorded activating and connecting to me

-Neither me or my friend have been able to see summon signs or be summoned whilst DSCFix was installed or after it was uninstalled

-After installing DSCFix, GFWL would not sign-in the first few launches, but fixed itself.


I used networktrafficviewer(I believe that is the correct name) and there are around 10 items incoming to port 3074(which I have forwarded along with 4 other ports for GFWL).


I believe this is every scrap of information I can provide concerning the topic. If there is anything else needed, I can provide. Thanks, in advance.

Link to comment
Share on other sites

  • 1 year later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...