Jump to content

Open Community  ·  196 members

Stardew Valley

Trying to get help and support?


MissCoriel

Recommended Posts

Hello I have a problem when I give artifacts or try to place a farm building, I can’t move as if my mouse no longer works and the directional arrow(zqsd) neither. It’s been doing this ever since I installed my first mods

I tried to remove all modes to know where it comes from but even with no mods it continues.

I’m extremely bad with computers so I’m really lost. So if anyone could help me, it would be really nice

ps: sorry for the mistakes I am French and dyx

I believe that my game log:

https://smapi.io/log/35751ded2c1140a5af445d9ab2fa59b7

Edited by Damefreyja03
Link to comment
Share on other sites

  • 1 month later...
  • 5 weeks later...

Hi hoping someone can help. Since updating SMAPI it no longer works. I went back to the older version I was using before (3.16.2) but it still isn't working. SMAPI isn't loading up at all, and when I launch Stardew Valley it only launches vanilla, despite me having the SMAPI path in the launch options.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Howdy. I regularly play with a lot of vanilla-based mods (retextures mostly, some character rewrites) and I can't figure out for the life of me what's causing the following issue:

When my farmer walks up to harvestable crops, or crops in general, he freezes, and the game stops moving. Weather will continue to move as though I am walking (ie rain falls as though you are walking), but my farmer is frozen, and I have to keymash to get unfrozen. It's like I get stuck in the collision, of some sort. These are also a lot of mods I've used before, so I have no clue why all of a sudden I'm getting stuck on walls. I'm going to continue troubleshooting each individual mod myself, but so far I haven't been able to pinpoint what's making me get stuck on my crops. The game doesn't crash, either; my character just seizes up for a while. It's kind of unplayable when you do get stuck so I'd like to fix it. I'd also like to figure out what mod it is so I can offer a bug report.

I'm not a coder and I don't really get code, so I'd really appreciate if someone better at this than me could figure out what sort of thing would be causing this... looping... boolean thing that repeats every frame I touch a plant and get frozen.

So far it's not alternative textures, pregnancy role, qi npc, any of my elle's animals mods, paths, ragdoll cat, animals die, animals need water, wind effects, or config menu (as far as I know. I've just been gutting mods and replacing them accordingly. I've been troubleshooting for a while...). I literally cannot fathom what's hooking me to my plants.

I do not get stuck on walls, animals, monsters, npc's, hoed ground,  rocks, artifact spots, or trees. Just crops and, for some reason, ginger roots on ginger island (the kind you hoe up). I am unsure if I'd get stuck on something like spring onion by extension but I don't know if that matters. I don't play with any sorts of movement mods or weird noclip mods, nor any mods that would be modifying crops or collision (as far as I know) anyways. 

The problem itself started only today. I had updated SMAPI last night but it wasn't doing this last night. I did download the following mods today to spice up the playthrough, so they're my primary suspects at the moment: obelisks mod??? Perhaps immersive family??? Custom babies??? I have no clue why that would affect anything like my crop collision. Anyways, I'm at a loss. Thanks in advance.

Here's my smapi error log:

https://smapi.io/log/52f1ad8c34034d95916eb81016d19db9

Link to comment
Share on other sites

I have been having persistent issues with Stardew Valley pausing when changing scene such as entering a new location e.g. entering the village or the mines. When this happens a black screen remains for a couple of minutes or more, sometimes as much as five minutes before the location eventually loads, then the game will continue as normal for a time but will pause in a similar manner at another point. This sometimes happens overnight too. The pauses usually get less after the game has been running for a while, as if the location has then been loaded into memory, but never is completely resolved. If I try to view the task manager (control, alt, delete) it will say the program (Stardew Valley) is not responding, but will come back after some time. 

 

Possibly related, I have been having ongoing issues with Stardew Valley Expanded mod, where some key events such as the boulder removal at the train station and the bomb quest at Marlon's Adventurers Guild don't complete properly i.e. the boulder never gets removed and for the bomb quest I never get access to the ledger. 

 

I have tried everything I can think of including going so far as to completely uninstall the game and all mods and reinstall but the problem always seems to return. I am guessing it may be a mod conflict issue as I do have quite a lot installed but don't know how to identify the specific mods causing the problem since smapi isn't reporting any errors that I can see. I am attaching my log though in the hope that others may be able to see what is happening:

 

https://smapi.io/log/d54315c0be9f49fa87c9e6a8d3dd49d5

 

Any help would be hugely appreciated! Many thanks in advance

Link to comment
Share on other sites

  • 2 weeks later...

Hey yall, I'm having a strangely new issue. I've been playing my first modded file for a bit (winter year 1, first day of the night market) and I'm suddenly having an issue where every few times I enter my farm, either from outside or from a building on the farm to outside the screen goes black, I can see my cursor and move it but nothing else happens. My code screen says "An error occurred in the base update loop: NullReferenceException: Object reference not set to an instance of an object.  error in modded stardew" with a bunch of repeats. I just have to shut the game down and try again, but in testing it, it doesn't happen every time I go in and out nor in a consistent pattern (like every two or three times) but very randomly. I've downloaded some new mods recently but have played without issue since. There's probably and easy fix but I'm new to mods so I'm not sure.

Any thoughts? And thanks in advance

https://smapi.io/log/7b5ea21175e44f0e89e6fb23481e087e

 

Link to comment
Share on other sites

  • 2 months later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...