Jump to content

Photo

Oblivion failing to detect my mouse clicks


  • Please log in to reply
21 replies to this topic

#1
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts
I decided to give Shivering Isles a whirl... after a bit of playing around in it, suddenly, Oblivion is not detecting me clicking my mouse. I click and I click. Clicking on menus, clicking on items, clicking on anything, really. So I tried to go to the controller options via the ESC key and using the arrow keys. Suddenly, those do not work specifically for one screen, and now I'm stuck on that screen. The arrow keys work fine - just when the buttons are arranged left to right rather than up to down, I cannot use them.

My mouse works perfectly. Oblivion detects (and works with) my mouse movements, my mouse wheel, and my keyboard. All other applications work perfectly with my mouse click.

Please help before I pull my hair out.

#2
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts
GRR! I wants to play Oblivion!

Anyway, I have recently discovered that it is not Shivering Isles causing this. I tried making a new game, and after making my new character (yes, it detected my clicks during making my character), the clicks suddenly stopped working.

Edited by NamenlosX, 15 May 2011 - 10:26 PM.


#3
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts
My .ini controls (could be related):

[Controls]
fVersion=1.8000
Forward=0011FFFF
Back=001FFFFF
Slide Left=001EFFFF
Slide Right=0020FFFF
Use=00FF00FF
Activate=0039FFFF
Block=003801FF
Cast=002E02FF
Ready Item=0021FFFF
Crouch/Sneak=001DFFFF
Run=002AFFFF
Always Run=003AFFFF
Auto Move=0010FFFF
Jump=0012FFFF
Toggle POV=0013FFFF
Menu Mode=000FFFFF
Rest=0014FFFF
Quick Menu=003BFFFF
Quick1=0002FFFF
Quick2=0003FFFF
Quick3=0004FFFF
Quick4=0005FFFF
Quick5=0006FFFF
Quick6=0007FFFF
Quick7=0008FFFF
Quick8=0009FFFF
QuickSave=003FFFFF
QuickLoad=0043FFFF
Grab=002CFFFF
bInvertYValues=0
fXenonLookXYMult=0.0005
fMouseSensitivity=0.0020
;X = 1, Y = 2, Z = 3, XRot = 4, YRot = 5, ZRot = 6
iJoystickMoveFrontBack=2
iJoystickMoveLeftRight=1
fJoystickMoveFBMult=1.0000
fJoystickMoveLRMult=1.0000
iJoystickLookUpDown=6
iJoystickLookLeftRight=3
fJoystickLookUDMult=0.0020
fJoystickLookLRMult=0.0020
fXenonMenuMouseXYMult=0.0003
bBackground Mouse=0
bBackground Keyboard=0
bUse Joystick=0
fXenonLookMult=0.0030
fXenonMenuStickSpeedMaxMod=5.0000
iXenonMenuStickSpeedThreshold=20000
iXenonMenuStickThreshold=1000
;Language values: 0-English, 1-German, 2-French, 3-Spanish, 4-Italian
iLanguage=0
Attack=00FF00FF
Ready Weapon=0021FFFF
Sneak=001DFFFF
Change View=001302FF
Journal=000FFFFF
Wait=0014FFFF
fXenonMenuStickMapCursorMinSpeed=1.0000
fXenonMenuStickMapCursorMaxSpeed=15.0000
fXenonMenuStickMapCursorGamma=0.1700
fXenonMenuStickSpeedPlayerRotMod=3000.0000
fXenonMenuDpadRepeatSpeed=300.0000
fXenonMenuStickSpeed=300.0000
iXenonMenuStickDeadZone=15000
SlideLeft=001EFFFF
SlideRight=0020FFFF

#4
HeyYou

HeyYou

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,377 posts
Are you trying to use a controller? Or keyboard and mouse? If you just want the keyboard and mouse disable the joystick in the oblivion.ini. I think its something like:

bUse Joystick=0

If you DON'T want to use a joystick, make sure it is set to zero.

#5
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts

Are you trying to use a controller? Or keyboard and mouse? If you just want the keyboard and mouse disable the joystick in the oblivion.ini. I think its something like:

bUse Joystick=0

If you DON'T want to use a joystick, make sure it is set to zero.

It is zero.
Keyboard and mouse, by the way.

#6
HeyYou

HeyYou

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,377 posts
Have any joysticks or such plugged in?? If so, unplug 'em. See what happens.

If that doesn't help, might try installing the klite basic codec pack. Be sure ffdshow is set to ignore oblivion, both audio and video, and it is set to repair broken codecs.

If you already have it, uninstall, and reinstall it.

#7
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts

Have any joysticks or such plugged in?? If so, unplug 'em. See what happens.

If that doesn't help, might try installing the klite basic codec pack. Be sure ffdshow is set to ignore oblivion, both audio and video, and it is set to repair broken codecs.

If you already have it, uninstall, and reinstall it.

I don't have ANY controllers besides mouse and keyboard.

#8
HeyYou

HeyYou

    Resident poster

  • Members
  • PipPipPipPipPip
  • 3,377 posts
Do the klite thing then, see if that works. (this is almost certainly a codec issue.....)

You can try disabling music in the oblivion.ini and see if that has any effect. Find the setting:

bmusicenabled=1

set it to zero. Try the game again.

#9
GetOutOfBox

GetOutOfBox

    Enthusiast

  • Supporter
  • PipPip
  • 130 posts
Go to Oblivion's directory in "Program Files", right click the executable (Oblivion.exe), select "Properties", and in the window that opens, click the "Compatibility" tab. Now select the boxes("check" them): "Disable Visual Themes", "Disable Desktop Compisition", and "Disable display scaling on high DPI resolutions". Click "Apply", then try starting Oblivion. I always select the first two boxes for games, as you may get a tiny, tiny performance boost from disabling the Windows Aero theme while in games, the 3rd option is one that often indirectly fixes mouse issues in games.

#10
NamenlosX

NamenlosX

    Journeyman

  • Members
  • Pip
  • 39 posts
Apparently, this mouse-click issue happens when somehow, my left click button appears to be stuck in the game (only it isn't actually stuck, the game thinks it is). For example, right now, after restarting my game and temporarily getting it to work, I'm now stuck at having my arrow drawn :(

I'll try the above suggestions.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.787 seconds