Jump to content

Photo

Skyrim 1.4 update and SKSE


  • Please log in to reply
23 replies to this topic

#1
Verinon

Verinon

    Journeyman

  • Members
  • Pip
  • 38 posts
I'm a newb to the modding scene. I just downloaded the 1.4 update on Steam and when I went to launch Skyrim, Script Extender reminded me that it was conflicting with the new update. Do I need to download a new version of SKSE now? Will all my mods still be running properly after all this?

Also, on a related note, will the mods I have now still work once the CK comes out? Or will I have to re-download them?

#2
Amasido

Amasido

    Regular

  • Members
  • PipPip
  • 98 posts
I would suggest you download the latest SKSE version, I have the patch and I'm not affected at all. Lastly when the ck comes out you won't be required to download all your mods again unless you want to, the mods stored on the steam workshop are independent of the mods you have already downloaded and will function more or less as normal.

#3
BlueTimJackel

BlueTimJackel

    Journeyman

  • Members
  • Pip
  • 22 posts
The SKSE site has a version for the beta - but presumably this is different from the official patch. I can't try it out now but I think we need to wait for SKSE to create an official update for this official patch.

EDIT:I take that back. SKSE site now specifically says:
Steam beta build: 1.4.8 (compatible with 1.4.21.0)

Edited by BlueTimJackel, 01 February 2012 - 09:18 PM.


#4
Verinon

Verinon

    Journeyman

  • Members
  • Pip
  • 38 posts
The SKSE site does have a new version out for the new patch, which I downloaded and installed in the right place, only to find that the items the folder (1.4) contains only has the 1.3 version in it. WTF?

EDIT: Okay, so I downloaded the SKSE 1.4.8 beta, copied the files to my Skyrim folder, booted up the game without any warnings popping up, but when I go to check that SkyUI is working, I find that it is not, which means that something is still wrong with SKSE.

EDIT: I just downloaded the new version (2.0) of SkyUI, installed it, booted up Skyrim without any warnings popping up again, and AGAIN SkyUI is still not working. What am I doing wrong? Do we just have to wait for an official new version of SKSE to come out? How long will that take? Because I can't play Skyrim until they do.

Edited by Verinon, 01 February 2012 - 09:43 PM.


#5
Caahauge

Caahauge

    Stranger

  • Members
  • Pip
  • 9 posts
The "same" problem occurs with ScriptDragon. It's newest update is for 2.4.15 so users of SD has to wait as well.

#6
iEvilClown

iEvilClown

    Stranger

  • Members
  • Pip
  • 2 posts
I'm having the same problem. Just need to hang on until SKSE gets and update.

#7
kingchris20

kingchris20

    Fan

  • Members
  • PipPipPip
  • 295 posts
for some reason, Steam isn't downloading the 1.4 update, I have it set to automatic download but nothing yet? anybody else have this problem?

#8
true_blue

true_blue

    Regular

  • Members
  • PipPip
  • 72 posts
Chris, try setting it to not update automatically and then closing properties and then set it back to download automatically. Thats how I forced mine to update.. failing that, restart steam!

I wish I hadn't updated now though coz both SKSE and SD are not working so I can't even play.. heh. No point progressing in the game coz I might mess a save up while those mods are disabled.

And the current SD is only for the beta, and not even the latest beta version. So I really hope that and SKSE are updated today/tomorrow! Maybe I will make another character until then :P

PS is there any way to roll back to v1.3?

Edited by true_blue, 02 February 2012 - 02:58 AM.


#9
Sunnie

Sunnie

    Girls, Girls, Girls!

  • Members
  • PipPipPipPip
  • 1,847 posts

Chris, try setting it to not update automatically and then closing properties and then set it back to download automatically. Thats how I forced mine to update.. failing that, restart steam!

I wish I hadn't updated now though coz both SKSE and SD are not working so I can't even play.. heh. No point progressing in the game coz I might mess a save up while those mods are disabled.

And the current SD is only for the beta, and not even the latest beta version. So I really hope that and SKSE are updated today/tomorrow! Maybe I will make another character until then :P

PS is there any way to roll back to v1.3?


SKSE has been updated for most of the day. Can't speak for SD, don't use it.
Rolling back is only possible if you backed up your 1.3.10 tesv.exe. If you didn't, well, start making backups of your executables and next time you can roll back! :thumbsup:

#10
drogmageddon

drogmageddon

    Stranger

  • Members
  • Pip
  • 8 posts
I updated to SKSE 1.4.21 and I keep getting errors and crashing before the game starts. I tried to load the game from the original Skyrim Launcher and I get "Your game version is not supported, supported patches; 1.1.21.0(31oct11)........1.3.10.0(18dec11) error and cant even run the game from launcher. Is this from not having an updated editor or did I mess things up some how?

Also, I am new to running games with mods, will running the game from the original launcher mess up anything with the mods (specifically the hideout mod, don't want to loose all my gear). I have been running Script dragon and SKSE but launching from TESV. Is this the right way to do it?

Thanks for any help, sorry .... tarded




Page loaded in: 1.214 seconds