Jump to content

Photo

Solution for [WETriggerScript<(01099883)> Warning: on init ()


  • Please log in to reply
51 replies to this topic

#51
LoganWolverine

LoganWolverine

    Regular

  • Premium Member
  • 85 posts

Hi guys, hope I`ll help most people with this problem:

The problem is in the file, that even clean install wont fix - its in C:\Users\-yourname-\AppData\Local\Skyrim

You need to modify your plugin list, plugins.ini

make sure there is only one Skyrim.esm and no Update.esm.

So your plugins.ini should look like:

=======
Skyrim.esm
plugins

=======
People already found out that problem is with the latest update, in one of the Dragon scripts.
That is temporary solution, but quite effective. Previous sugeestions failed to solve the problem, so I tried to dig more and found this solution. Hope Betheasda will fix it asap.

Please write if it helped.

I'm no expert about these things and I've searched all over the net for an answer to the problem, WeTriggerSript ERROR (................) Blah Blah..........

 

So here's what I did I looked all over the net and everyone says oh go look in C:\Users\LoganSniper\AppData\Local\Skyrim\plugin.ini and check for double skyrim.esm listed there and remove one of them and then all will be good, NOT!!!!!!!!!. It wasn't there.

 

So then as a last ditch effort I searched for a script called What? That's right "WETriggerScript.pex". Now the quick and dirty of it all is just a single edit to the script as Follows:

 

"getMyHoldFactionControllerMarker ETX Off" This is the default setting, but I set this to "ON" and then went in to the game and ran all over the place both in Solstheim and in Skyrim and never again did I get the error message.

 

Now the editor I used was Notpad ++ and this entry is found on line 2 of the editor about the middle of the line starting with "OnCellLoad"

 

I don't know if this is a cure all for this problem or not but it seems to be working really well for me right now so I hope this helps Someone or maybe gives someone that has more knowledge than I the means to finally put this beast to rest and fix this problem properly.



#52
Arthmoor

Arthmoor

    Black Hand

  • Premium Member
  • 7,119 posts

Hate to say it, but that's not a solution to the problem at all. Especially directly editing a compiled script file. There is no defect in the script itself. In fact, the changes you've caused to it will break numerous wilderness encounters in the game since that's what the script is used for.

 

As this thread has been repeatedly saying, the problem lies squarely with the plugins.txt file in the AppData folder. Two or more lines with Skyrim.esm listed. Remove all but one. Problem will be solved every time.

 

This is NOT a vanilla game error either. It's caused by mod management programs making improper updates to the plugins.txt file when they're used. Your fix has not resolved this problem and you will find that the game is double loading all of the master data.






Page loaded in: 0.898 seconds