Jump to content

Papyrus Notepad++ Compilation Failure


Recommended Posts

I'm trying to learn scripting for Skyrim Legendary Edition and I'm following the Notepad++ Setup on the Creation Kit wiki, but I'm having an issue where it fails to compile on ScriptCompile.bat.



C:\Program Files\Notepad++>cd "D:\Steam\steamapps\common\Skyrim\Papyrus Compiler"
C:\Program Files\Notepad++>"D:\Steam\steamapps\common\Skyrim\Papyrus Compiler\PapyrusCompiler.exe" "ScriptCompile.bat" -f="D:\Steam\steamapps\common\Skyrim\Data\scripts\Source\TESV_Papyrus_Flags.flg" -i="D:\Steam\steamapps\common\Skyrim\Data\scripts\Source" -o="D:\Steam\steamapps\common\Skyrim\Data\scripts"
Starting 1 compile threads for 1 files...
Compiling "ScriptCompile.bat"...
<unknown>(0,0): unable to locate script ScriptCompile.bat
No output generated for ScriptCompile.bat, compilation failed.
Batch compile of 1 files finished. 0 succeeded, 1 failed.
Failed on ScriptCompile.bat
C:\Program Files\Notepad++>pause
Press any key to continue . . .


Here are the steps I've taken:

  • I extracted all the Skyrim scripts from Scripts.rar and placed them into the Scripts data folder.
  • I opened Notepad++, hit the run key (F5), and typed the following in the dialogue window:
    • "D:\Steam\steamapps\common\Skyrim\Papyrus Compiler\ScriptCompile.bat" "$(FILE_NAME)" "$(CURRENT_DIRECTORY)"
  • I save the shortcut "Compile Papyrus" as "Ctrl + Shift + F5"
  • I then edited and saved ScriptCompile.bat to the following:
    1. cd %2
    2. "D:\Steam\steamapps\common\Skyrim\Papyrus Compiler\PapyrusCompiler.exe" %1 -f="D:\Steam\steamapps\common\Skyrim\Data\scripts\Source\TESV_Papyrus_Flags.flg" -i="D:\Steam\steamapps\common\Skyrim\Data\scripts\Source" -o="D:\Steam\steamapps\common\Skyrim\Data\scripts"
    3. pause
  • I run the Compile Papyrus shortcut and it gives me the error shown above.
I have no experience with scripting and I thought I would use Skyrim as a way to learn, but this has me completely stuck and I don't have the experience to know where to go from here.
I have looked at others with similar issues, but no advice that I've tried has worked. I made sure the file paths are the same as on my computer, I made sure the scripts are in my data folder (not in MO2), and I made sure not to change any of the text outside of the quotation marks. I'm honestly not sure what else to try. If I've made any mistakes, I would like to know what they were.




Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...