Jump to content

Vortex 1.3.22 Downloading/Installing Mods Issue


Recommended Posts


Sorry to hear you're having problems downloading from Nexus Mods. We'll need to know more about your setup before we can help you.
Please check out our troubleshooting guide for quick fixes.


hey there, i also began having this problem just today, i have been reading the trouble shoot guid and everything, i tried checking my firewall and everything, but the thing is, i can only download files less than 2mb, but then i tried to download with vpn, still didn't work. but manual download worked with vpn, but it's downloading at the speed of 45-50kb/s and it just keeps failing every 20 seconds or so. my internet connection also seems to be fine, no trouble on other websites for now. can i provide any info so that you can help me out?

Link to comment
Share on other sites

  • 2 years later...

This is the error I just started getting 2 weeks ago. I'm using the current Vortex Version 1.9.3. My system has 24GB of memory and I'm currently using Windows 11 after reinstalling. Windows 10 did the same thing. My internet is 100 down and 30 up. I had no problems this time last year modding Fallout 4 or Skyrim SE in March of this year.

I can download small mods no problem, but any of the larger ones I get the error 'Download Failed'


When I do an 'Inspect' on the download I get the following:


Network connect was not permitted, please check your firewall settings
port: 443
Error: connect ETIMEDOUT
at_node_internal_captureLargeStackTrace (node:interal/error:490:5)
at_note_internal_exceptionWithHostPort (node:internal/errors:668.12
at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1494:16)
I've added Vortex to the Firewall and turned Chrome 'off & on' in the Firewall as well. I've changed UAC to Full Control for BlackTree Gaming folder (vortex) and for Google Chrome.
I've also added Vortex and Chrome to the Exclusions list through Windows Security.
I've even tried downloading with the Firewall off!
Nothing has made any difference.
If anyone can help with a fix or suggestion that would be very much appreciated. I've run out research options and ideas! Thanks :smile:


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...