Jump to content

Persistent NET Framework Error.

Go to solution Solved by Pickysaurus,

Recommended Posts

Vortex Version: (Update failing- possibly related?)

Games Managed: Skyrim SE, Fallout: New Vegas

Game Source: Steam

OS: Windows 10, Standard, x64

Mod Load: 70~

It's been a while since I've touched Skyrim or Vortex, and since then I've done some pretty intensive system upgrades. But I finally decided to try and get Skyrim working again after Bethesda's "latest and greatest" update. Most of my mods are texture/visual mods and were fine- yet I decided to touch up four that likely broke (one confirmed). Two are set up to use Vortex. So here we begin with Vortex unsurprisingly barking 5-6 errors at me, which is expected when you've not used something in about a year. I fixed all but two- and yet one prevents anything at all from happening. Anytime I start a file install, Vortex tells me I need to install NET desktop runtime. Instantly and without fail, locking Vortex from performing most actions.

Except I've already got a newer version installed, ran the installer for the linked 6.0.28 in both x64 and x86 just to be very sure, confirmed they are installed with WISE uninstaller, and no other program is having any issue that I know has required some form of NET desktop runtime to work. This is isolated, and entirely on Vortex itself. Vortex also refuses to update- unsure this is entirely related, but apparently newer versions are available.

I initially thought this was because I switched browsers to one that was Firefox based, which meant I had no default system browser. It's a Windows registry issue, and it is able to be fixed- but reinstalling Chrome was easier than messing with registry scripts. And re-installing Chrome to set a default browser did nothing. Vortex's attempts to repair bring up no window, and end fruitless. I don't really see what it would have to repair with fresh NET installs and the newer versions also being confirmed to be stable by their own installers, and by virtue of literally every other program I have running fine.

I'm about to try full uninstalls and re-installs, namely for Vortex itself- but I'm not quite sure what its problem is. Nothing I run is unusual, and even after my system upgrades, I've been making sure to clean and organize. Nothing is pirated/cracked, and historically has been incredibly smooth in operation. I don't even really care about the update issue unless it's necessary for Vortex to do its job- which it did, but all I've gleaned from the internet so far is that there's a GitHub post from 2021 about NET errors that was a dead end. I'd appreciate any leads on a fix, or alternatives. I've looked at Wabbajack and MO2, but I don't think they do quite the same thing as Vortex.

Attached below are some supporting clips. If there's logs that need uploaded, I'll hunt them down.




Link to comment
Share on other sites

Much appreciated. No idea how that didn't show up when I was poking around for NET related issues, but all I had to do was run the command prompt lines for permissions and it appears everything is working now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...