Jump to content

Photo

Uninstalled mod is showing installed

installed mods uninstalled mods vortex mods friendlyhuduninstalled mods vortex mods friendlyhud mod

Best Answer Pickysaurus , 20 June 2020 - 09:53 PM

To drop down menu is a toggle, the currently active version is uninstalled, but if you toggle to another version you may see it's marked "disabled" instead

Go to the full post »


  • Please log in to reply
20 replies to this topic

#1
Odylarian

Odylarian

    Regular

  • Members
  • PipPip
  • 55 posts

Don't know if this is a bug with Vortex or not.  Wanna see if the community has a solution before I report as a bug.

I am trying to install the FriendlyHUD mod for Witcher 3. Vortex is showing the mod as uninstalled. (See attachment).  However, when I try to install it, I get a warning saying the mod appears to already be installed. (see attachment).  You can see from my mod listing, it is not already installed. (see attachments).  I went out of Vortex and back in, but still doing that same thing.

Of course, I can just reinstall it, but I wanted to see if this is a bug, a known glitch or something easily fixed.

 

Any advice?

 

Some background:  I had installed the mod and ran Script Merger.  There were something like 68 conflicts, so I said, "To hell with dat, I'm gonna uninstall it", which I did. Now I have this problem.  BTW:  Script merger is also showing this mod as being installed but overridden by a higher priority mod.
 

Attached Files


Edited by Odylarian, 20 June 2020 - 09:17 PM.


#2
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 12,667 posts

See you drop down on the version number? That means you have other, older versions of that mod installed, so the message is correct.



#3
Odylarian

Odylarian

    Regular

  • Members
  • PipPip
  • 55 posts

Pickysaurus, far be it from me to argue with an expert like you, but the version drop down is in the Uninstalled section also. If one version was uninstalled and one installed, shouldn't the mod be listed in both places?  BTW: Just wondering, if the version drop down is showing multiple versions in the installed section, does that mean I have more than one version installed?  I have always wondered about this.


Edited by Odylarian, 20 June 2020 - 09:53 PM.


#4
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 12,667 posts
✓  Best Answer

To drop down menu is a toggle, the currently active version is uninstalled, but if you toggle to another version you may see it's marked "disabled" instead



#5
Odylarian

Odylarian

    Regular

  • Members
  • PipPip
  • 55 posts

You are right.  I toggled the other version of the mod and *viola*, it installed a newer version.    I still think it should put one version in uninstalled and another in installed if one is already installed so you can see it in the installed section.  BTW:  I came across another slightly related issue.  In my disabled section I had the Absolute Camera mod.  In the Content Column it said "empty".   FYI:  ALL the disabled mods say "Empty" in the content section.  Odd.  Anywho,  I enabled the mod to see what would happen.  It DID enable it and I had to push the "Deploy" button to deploy it. Yet it still said "Empty" in the Content column.  I looked in the MOD folder and, sure enough, there was nothing in the directory for that mod. Sooo, I removed that mod (kept the archive) and manually installed the mod via file.  Now it is fine.

 

I think this may have happened when I first enabled the game in Vortex (after 3-4 months).  It had me download a new version of script merger and gave me an odd message that my deployment method was invalid.  However, it won't let me change my deployment method. It is currently set as "symlink deployment".   Yes, the staging folder and the game folder are on the same drive.  I reported this as a bug today.

 

Thank you.
 



#6
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 14,742 posts

The way I use the "Version" drop down, is The Installed Version always is the one showing by default, so I click the dropdown, click the Flathead Screwdriver Symbol to uninstall and/or delete the old version, then when that's done, I just install the new versio, vortex remember where in the load order it was, so it just puts it back in place



#7
Odylarian

Odylarian

    Regular

  • Members
  • PipPip
  • 55 posts

Thank you HadtoRegister for that advice.  I thought Vortex was s'pose to handle the uninstalling and installing automatically when you updated the version of a mod.  Why would it keep both versions?



#8
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 14,742 posts

Thank you HadtoRegister for that advice.  I thought Vortex was s'pose to handle the uninstalling and installing automatically when you updated the version of a mod.  Why would it keep both versions?

 

 

No, it never Automatically uninstalled the old version and installed the new version, because people would seriously be complaining about that if it did.

The drop down let's you easily and conveniently switch between versions, or to "clean house" of the older version once they aren't needed anymore.
If the mod page has the old versions posted, I will "Remove" the old version and check the "Delete Archive" box, because I know I can still download it from Nexus.
But if it's a New version of a Mod where the Mod page doesn't keep the old versions, I will just pick "Uninstall" and then install the newer version, in order to keep the older version "Just in case"



#9
Odylarian

Odylarian

    Regular

  • Members
  • PipPip
  • 55 posts

OK HadToRegister.  I see your logic. Now that I know it doesn't automatically uninstall the old version, I can do what you suggested.

 

I have another related issue.  I am having compiler trouble with Witcher 3.  I am getting compiler errors when starting the game, but it is on scripts that do NOT even show up in the Script Merger, so I don't know how to fix them.  Anywho,  I uninstalled ALL my mods and reverted the Unification Patch back to the base game (in case that was the cause).  Here is my issue.  When I run the script merger, it is showing script conflicts for mods that are not even installed.  Howse that?  Do I have a secret "stash" of enabled scripts somewhere that the Script merger is picking up?  I dunno.  Any help would be appreciated.

Additional info:  Eventhough I uninstalled all my mods, my load order screen was showing "Mods not managed by Vortex".  By googling, I learned that I had installed mods using WMM (that old warhorse) and uninstalled those mods in WMM and cleared the "mod.settings" file. Now my load order screen is blank, but Script merger still shows scripts with conflicts. Odd!

Let me let you also know that my deployment method is "symlink" even though my staging folder is on the same drive as the game folder. It won't let me change it to "hardlink".  Odd!  Dunno if this is contributing to my script conflict issue.

Thank you.



#10
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 14,742 posts

OK HadToRegister.  I see your logic. Now that I know it doesn't automatically uninstall the old version, I can do what you suggested.

 

I have another related issue.  I am having compiler trouble with Witcher 3.  I am getting compiler errors when starting the game, but it is on scripts that do NOT even show up in the Script Merger, so I don't know how to fix them.  Anywho,  I uninstalled ALL my mods and reverted the Unification Patch back to the base game (in case that was the cause).  Here is my issue.  When I run the script merger, it is showing script conflicts for mods that are not even installed.  Howse that?  Do I have a secret "stash" of enabled scripts somewhere that the Script merger is picking up?  I dunno.  Any help would be appreciated.

Additional info:  Eventhough I uninstalled all my mods, my load order screen was showing "Mods not managed by Vortex".  By googling, I learned that I had installed mods using WMM (that old warhorse) and uninstalled those mods in WMM and cleared the "mod.settings" file. Now my load order screen is blank, but Script merger still shows scripts with conflicts. Odd!

Let me let you also know that my deployment method is "symlink" even though my staging folder is on the same drive as the game folder. It won't let me change it to "hardlink".  Odd!  Dunno if this is contributing to my script conflict issue.

Thank you.

 

 

Yes it's contributing.

Witcher 3 is a special case, because it needs the game to be on C:\, along with the Witcher Mod Staging Folder on C:\, because it also need to access the appdata, or some other folder in order to be able to pick Hardlink

If you go with Symlink (Although I heard tell that the Script Merger now works with SYmlinks) the merging won't work

YOu might want to try MOVE Method







Also tagged with one or more of these keywords: installed mods, uninstalled mods, vortex, mods, friendlyhuduninstalled mods, vortex mods, friendlyhud mod

Page loaded in: 1.058 seconds