Jump to content
Heavy Traffic ×

Mods not taking effect on new Skyrim SE game


1024RF
Go to solution Solved by Pickysaurus,

Recommended Posts

I tried changing the Achievements and Screen Saver settings to false, per above, but no joy. I even disabled the Engine Fixes mod, and couldn't run any of my mods. It seems that Bethesda has broken Vortex functionality.

At least we can see the influence of Microsoft here! Next thing, it won't let you play any Bethesda game unless Edge is your default browser and Bing your search engine!

 

Anyway, I'm not sure what to do, other than hope that a Vortex update fixes this... *sad face*

Link to comment
Share on other sites

1 hour ago, vortexposer said:
Setting plugins.txt to read-only essentially breaks Vortex Plugins tab functionality and you shouldn't need to force anything in such a way. There must be an external change occurring to cause this outside of Vortex itself. E.g. Engine fixes type bug or letting ingame manager rewrite plugins.txt by accessing the creations/mods menu, etc.
 

I completely agree that we should not have to do this! It is clearly not the intended use. I can tell you that I have never touched the Bethesda in-game mod manager - never logged in, never clicked on the menu item in the Game start menu. It's entirely possible the in-game manager is now overwriting or causing the game to not recognize the Vortex-generated plugins.txt, and if that's what's happening then it is doing so without any input from the user - at least in my specific case. I was able to play Skyrim tonight by setting that file to read only before launching, so until anyone has a better idea it seems that's what it takes.

Link to comment
Share on other sites

@Pickysaurus For visibility, in case you haven't seen this.  Although, if this was a universal problem, I feel more people would be reporting it.  It should still be looked at on the dev side, if only to confirm it is a mod issue (Engine Fixes or another) and not an issue between Vortex and the in-game mod manager.  I am GOG version, so can't test it myself (unless Vortex can somehow deal with two instances of the same game).  Thanks.

 

 

Link to comment
Share on other sites

Thanks for looking at it. It is definitely an issue, but I'll try to give more info. Running Vortex 1.9.10

image.thumb.jpeg.ed7525ef4adeae8bee3ae82ab5398b1e.jpeg

I run the Skyrim Script Extender 64, which I just updated to  2.2.5 from Silverlock.org

When I load a saved game, I get a pop-up with a list of installed dll's for the game that are not enabled in the Creations menu. It's, essentially, my mod list, including things like SKSE64 and bunches of Vortex mods. I also can't screen grab from the game - it doesn't take the Steam shortcut for screen captures anymore, either.

I think the new update plays with Plugins.txt - overwrites it with what's in the creations bin, but I don't have anything from there.

I do wonder if shifting to Skyrim LE and modding it will bypass this mess.

 

Thanks again,

Brian

Link to comment
Share on other sites

  • 2 weeks later...
On 12/10/2023 at 2:35 AM, AmenRa333 said:

Figured id post this since even with disabling achievements in SSE Engine fixes. The game was still not loading any of my mods.

Alright so found a solution to get things playable for myself with all this Bethesda Bs.

So Vortex plugins kept getting disabled a setting in SSE Engine Fixes mod. So if your using that mod, go to your Data folder, open EngineFixes.toml with notepad++ and find and set to EnableAchievementsWithMods = false.

This should stop vortex from disabling every plugin every time you start it up.

Once you get your plugins all updated/enabled, go to %localappdata% then Skyrim Special Edition, and set Plugins.txt to read only. Skyrim SE/AE should now actually load your mods. So provided you did a butt ton of mod updates and got rid of mods with incompatible .dlls you should be good to go.

Just remember if you need to change things in vortex/mo2 you have to remove the read-only from Plugins.txt.

I did both steps. Nothing changed. I still get the message "This save relies on Creations you have already downloaded, but are currently inactive:"

followed by the message "The following content is not present" and then a long list; perhaps all of my mods.

 

So this is still unsolved for me at least. I'm pretty sure I'm not the only one. 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...